Trouble installing gems with jruby 1.1.6


#1

I’m trying to install rails with 1.1.6 on windows xp, but I get the
following issue, probably due to the ø in my last name:

This is the output from jruby

C:\jruby-1.1.6\bin>jruby -S gem install rails
JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - No such file or directory - d:/Documents
and
Settings/Stefan Landr�

C:\jruby-1.1.6\bin>

And this is my actual home directory:

D:\Documents and Settings\Stefan Landrø

How can I solve this issue?

Cheers,

Stefan


#2

On Thu, Feb 5, 2009 at 10:43 AM, Stefan Magnus Landrø
removed_email_address@domain.invalid wrote:

Settings/Stefan Landr�

C:\jruby-1.1.6\bin>

And this is my actual home directory:

D:\Documents and Settings\Stefan Landrø

How can I solve this issue?

Ouch, looks like a windows file encoding issue. Can you please file a
bug?

As a workaround, try setting GEM_HOME explicitly, or also try
temporarily setting HOME to something other than your current HOME.

/Nick


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

Stefan Magnus Landrø wrote:

and Settings/Stefan Landr�
Only reason I can think of it might be going after your home dir would
be for a temp location. Can you try to set TEMP env var to something
without spaces or unicode chars and try again?

  • Charlie

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

oops, I guess I was a little bit quick - installing the ri still
crashes…


d:\Documents and Settings\Stefan Landro>set
USERPROFILE=c:\jruby\user_profile

d:\Documents and Settings\Stefan Landro>set GEM_HOME=c:\jruby\gem_home

d:\Documents and Settings\Stefan Landro>jruby -S gem install rails
JRuby limited openssl loaded. gem install jruby-openssl for full
support.
http://wiki.jruby.org/wiki/JRuby_Builtin_OpenSSL
Successfully installed activesupport-2.2.2
Successfully installed activerecord-2.2.2
Successfully installed actionpack-2.2.2
Successfully installed actionmailer-2.2.2
Successfully installed activeresource-2.2.2
Successfully installed rails-2.2.2
6 gems installed
Installing ri documentation for activesupport-2.2.2…
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory - No such file or directory - d:/Documents
and
Settings/Stefan Landrø

d:\Documents and Settings\Stefan Landro>

2009/2/6 Stefan Magnus Landrø removed_email_address@domain.invalid


#5

Hi there,

I actually had to modify both GEMS_HOME and USERPROFILE to make gem run
properly. I’ll file an issue in the jira.

Thanks for your help.

Stefan

set USERPROFILE=c:\jruby\user_profile
set GEM_HOME=c:\jruby\gem_home

2009/2/5 Charles Oliver N. removed_email_address@domain.invalid


#6

Yeah, the gem should be installed fine, you just won’t have any
documentation :wink:

/Nick

On Fri, Feb 6, 2009 at 2:24 AM, Stefan Magnus Landrø
removed_email_address@domain.invalid wrote:

JRuby limited openssl loaded. gem install jruby-openssl for full support.
No such file or directory - No such file or directory - d:/Documents and

properly. I’ll file an issue in the jira.

Stefan Magnus Landrø wrote:

ERROR: While executing gem … (Errno::ENOENT)
To unsubscribe from this list, please visit:


Bekk Open Source
http://boss.bekk.no


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#7

I had the same problem. When I sat GEM_HOME and USERPROFILE I could
install
the gems, but they didn’t work as expected. If I only set HOME before
installing the gems (not GEM_HOME and USERPROFILE) everything works.

landro wrote:

(…)


View this message in context:
http://www.nabble.com/Trouble-installing-gems-with-jruby-1.1.6-tp21855812p23595889.html
Sent from the JRuby - User mailing list archive at Nabble.com.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email