Trouble installing acts_as_taggable_on_steroids

Hi,

I get this error when trying to install the plugin. Can anybody help?

$ ruby -d script/plugin install
git://github.com/jviney/acts_as_taggable_on_steroids.git
Exception LoadError' at /Library/Ruby/Site/1.8/rubygems.rb:1113 - no such file to load -- rubygems/defaults/operating_system ExceptionNoMethodError’ at
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rational.rb:78

  • undefined method gcd' for Rational(1, 2):Rational ExceptionLoadError’ at
    /Library/Ruby/Site/1.8/rubygems/config_file.rb:34 - no such file to load
    – Win32API
    Exception LoadError' at /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31 - no such file to load -- Win32API ExceptionLoadError’ at
    /Library/Ruby/Site/1.8/rubygems/custom_require.rb:38 - no such file to
    load – Win32API
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:411:
    warning: method redefined; discarding old plugins
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized
    /Users/andersw/.gem/ruby/1.8/gems/rails-2.3.4/lib/commands/plugin.rb:309:
    warning: instance variable @rails_env not initialized

$ gem -v
1.3.5

$ rails -v
Rails 2.3.4

(I’m using Mac)

Regards,
Abigail

I had almost the same error begining but trying to use net-ssh on ubuntu
without rails (yet)

Exception LoadError' at /usr/lib/ruby/1.8/rubygems.rb:1113 - no such file to load -- rubygems/defaults/operating_system ExceptionNoMethodError’ at /usr/lib/ruby/1.8/rational.rb:78 -
undefined method gcd' for Rational(1, 2):Rational ExceptionLoadError’ at /usr/lib/ruby/1.8/rubygems/config_file.rb:34 -
no such file to load – Win32API
Exception `LoadError’ at /usr/lib/ruby/1.8/rubygems/custom_require.rb:31

  • no such file to load – net/ssh
    Exception `LoadError’ at /usr/lib/ruby/1.8/rubygems/custom_require.rb:31
  • no such file to load – highline
    Exception `LoadError’ at /usr/lib/ruby/1.8/rubygems/custom_require.rb:38
  • no such file to load – highline
    Exception `LoadError’ at /usr/lib/ruby/1.8/rubygems/custom_require.rb:31
  • no such file to load – termios
    Exception `LoadError’ at /usr/lib/ruby/1.8/rubygems/custom_require.rb:38
  • no such file to load – termios
    Exception `Net::SSH::Exception’ at
    /var/lib/gems/1.8/gems/net-ssh-2.0.15/lib/net/ssh/transport/algorithms.rb:296
  • could not settle on language_client algorithm
    Exception `Net::SSH::Exception’ at
    /var/lib/gems/1.8/gems/net-ssh-2.0.15/lib/net/ssh/transport/algorithms.rb:296
  • could not settle on language_server algorithm
    /var/lib/gems/1.8/gems/net-ssh-2.0.15/lib/net/ssh.rb:192:in `start’:
    Net::SSH::AuthenticationFailed
    from sshtry.rb:14

I’m running:

[email protected]:~$ gem -v
1.3.5
[email protected]:~$ ruby -v
ruby 1.8.7 (2009-06-12 patchlevel 174) [i486-linux]
[email protected]:~$ uname -a
Linux eric-box 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC
2009 i686 GNU/Linux

Regards!

Eric

Thanks for your reply. I went with acts_as_taggable_on which was
available as a gem and seem to work fine.