To_remote working only in ie?

hi

i have remote link with spinner. The problem is that only works in ie

<%= link_to_remote user.username, :url => { :action => ‘fetch’,
:controller => ‘users’, :user => user.id},
:update => { :success => ‘good_div’,
:failure => ‘error_div’ },
:complete => “Element.hide(‘spinner’)”,
:loading => “Element.show(‘spinner’)”%>

and spinner:

spinner

It is working fine with internet explorer, but in firefox it doesn`t
hide spinner element, it is always on screen.

what am i doing wrong here?

thanks all

serz

did you try

<%= link_to_remote user.username, :url => { :action => ‘fetch’,
:controller => ‘users’, :user => user.id},
:update => { :success => ‘good_div’,
:failure => ‘error_div’ },
:loading => “Element.toggle(‘spinner’)”,
:complete => “Element.toggle(‘spinner’)”

                       %>

sine serz wrote:

hi

i have remote link with spinner. The problem is that only works in ie

<%= link_to_remote user.username, :url => { :action => ‘fetch’,
:controller => ‘users’, :user => user.id},
:update => { :success => ‘good_div’,
:failure => ‘error_div’ },
:complete => “Element.hide(‘spinner’)”,
:loading => “Element.show(‘spinner’)”%>

and spinner:

spinner

It is working fine with internet explorer, but in firefox it doesn`t
hide spinner element, it is always on screen.

what am i doing wrong here?

thanks all

serz

Steven Albarracin wrote:

did you try

<%= link_to_remote user.username, :url => { :action => ‘fetch’,
:controller => ‘users’, :user => user.id},
:update => { :success => ‘good_div’,
:failure => ‘error_div’ },
:loading => “Element.toggle(‘spinner’)”,
:complete => “Element.toggle(‘spinner’)”

                       %>

hi steven, yes it works fine now.

thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs