Tip: page_attachments extension needs submodule initialized


#1

Just a quick tip (and maybe bug report? not sure)…

I tried a simple ./script/extension install page_attachments in my
Radiant 0.6.9 instance and got

rake aborted!
undefined method `has_attachment’ for PageAttachment(Table doesn’t
exist):Class

The problem was attachment_fu was missing. It’s included via git
submodule, but isn’t pulled along with the clone. So, you have to cd to
the page_attachments extension and

git submodule init
git submodule update

Then cd back up to the app root and rake db:mgrate:extensions and rake
radiant:extensions:update_all.

That should take care of it. Maybe this workaround means I’m doing
something wrong, but I at least wanted to put it out there for people
googling that error message.

Sean, thanks for maintaining the page_attachments extension! I tried
out paperclipped, but it’s too much for my users. They get the
simplicity of page_attachments.

Jason G.


#2

Sean, thanks for maintaining the page_attachments extension! I tried
out paperclipped, but it’s too much for my users. They get the
simplicity of page_attachments.

I’ve handed out maintenance to a couple active developers on it as
well. I’m sorry about the script/extension install issue. It’s
supposed to initialize git submodules automatically.

Sean


#3

Just fixed this in edge:
http://github.com/radiant/radiant/commit/5d957241ee6c9f2c040c5f17882976b56902f641
http://github.com/radiant/radiant/commit/c92cf42482c22f81674712b8e1b47d511661db7e

Cheers,

Sean