Timeout updating system


#1

Hi

I’ve just installed Ruby (186-27) using the one-step installer on
Windows
(XP SP3). I want to install Watir, so I need to update the system.
However,
when I run “gen update --system” I get:

Updating RubyGems
WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance.
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
timed out (http://gems.rubyforge.org/Marshal.4.8)

The output from “gem list --local” is:

*** LOCAL GEMS ***

fxri (0.3.6)
fxruby (1.6.16)
hpricot (0.6.164)
log4r (1.0.5)
ptools (1.1.6)
rake (0.8.1)
ruby-opengl (0.60.0)
test-unit (2.0.1)
win32-api (1.2.1, 1.2.0)
win32-clipboard (0.4.4)
win32-dir (0.3.2)
win32-eventlog (0.5.0)
win32-file (0.5.5)
win32-file-stat (1.3.1)
win32-process (0.5.9)
win32-sapi (0.1.4)
win32-sound (0.4.1)
windows-api (0.2.4)
windows-pr (0.9.3)

The output from “gem env” is:

RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.1
  • RUBY VERSION: 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
  • INSTALLATION DIRECTORY: c:/ruby/lib/ruby/gems/1.8
  • RUBY EXECUTABLE: c:/ruby/bin/ruby.exe
  • EXECUTABLE DIRECTORY: c:/ruby/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86-mswin32-60
  • GEM PATHS:
    • c:/ruby/lib/ruby/gems/1.8
    • U:/.gem/ruby/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

I’m on a gigabit JANET Internet link, and we have no Web proxy. I can
access
the URL it’s complaining about, so I’m baffled as to what’s going on.
This
is now the third time I’ve installed Ruby (I did uninstall each time,
too),
and on previous occasions I tried downloading the individual components
and
updateing them locally, but there are so many to update and so many
dependencies that I gave up. Does anyone have any idea what’s going on?

Max Caines
IT Services, University of Wolverhampton
Wolverhampton, West Midlands WV1 1SB
Tel: 01902 322245 Fax: 01902 322777


#2

I’m on a gigabit JANET Internet link, and we have no Web proxy. I can
access
the URL it’s complaining about, so I’m baffled as to what’s going on.
This
is now the third time I’ve installed Ruby (I did uninstall each time,
too),
and on previous occasions I tried downloading the individual components
and
updateing them locally, but there are so many to update and so many
dependencies that I gave up. Does anyone have any idea what’s going on?

For some reason rubygems times out for me at times, too.
I’d recommend just downloading the latest rubygems code and installing
it.
-=r


#3

On Jun 9, 2009, at 02:50, Caines, Max wrote:

I’ve just installed Ruby (186-27) using the one-step installer on
Windows (XP SP3). I want to install Watir, so I need to update the
system. However, when I run “gen update --system” I get:

Updating RubyGems
WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance.
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
timed out (http://gems.rubyforge.org/Marshal.4.8)

What does gem update -V --system say?


#4

-----Original Message-----
From: Eric H. [mailto:removed_email_address@domain.invalid]
Sent: 09 June 2009 23:23
To: ruby-talk ML
Subject: Re: Timeout updating system

What does gem update -V --system say?

It says:

C:\Ruby\bin>gem update -V --system
Updating RubyGems
connection reset after 1 requests, retrying
connection reset after 1 requests, retrying
connection reset after 2 requests, retrying
connection reset after 1 requests, retrying
connection reset after 2 requests, retrying
connection reset after 1 requests, retrying
ERROR: http://gems.rubyforge.org/ does not appear to be a repository
ERROR: While executing gem … (Gem::RemoteFetcher::FetchError)
too many connection resets (http://gems.rubyforge.org/yaml)

Thanks

Max