Time to back peddle? (Ruby 1.8.7)


#1

I just updated my Ubuntu system and was a bit surprised to find:

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?


#2

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

For better or worse, the 187 branch is basically the only one that gets
any attention from the core developers [i.e. patches] so…I’d say
either one is ok.
-=R


#3

On Nov 26, 7:55 am, Trans removed_email_address@domain.invalid wrote:

I just updated my Ubuntu system and was a bit surprised to find:

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

This happened to me, and it was an “uh-oh” moment for me too. I think
my bad feeling about it comes from Rails. Although I’ve heard that
Rails 2.1+ has 1.8.7 compatibility, the official site (http://
www.rubyonrails.org/down) hasn’t been updated with respect to its
stance on ruby versions.

– Mark.


#4

On Wed, Nov 26, 2008 at 9:55 PM, Trans removed_email_address@domain.invalid wrote:

I just updated my Ubuntu system and was a bit surprised to find:

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

Using it since the release in spring, had an issue in the prerelease
version, but nothing bad happened since.


#5

As you may know Ruby 1.8.7 don’t compatable with
Rails(http://www.rubyonrails.org/down)
We recommend Ruby 1.8.6 for use with Rails. Ruby 1.8.7, 1.8.5, 1.8.4 and
1.8.2 are still usable too, but version 1.8.3 is not.
Ruby 1.8.7 still has some bugs to straighten out.

Step-by-step to downgrade Ruby to 1.8.6 manual
http://railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1-8-7-to-1-8-6

Daniel B. wrote:

On Nov 26, 5:55�am, Trans removed_email_address@domain.invalid wrote:

I just updated my Ubuntu system and was a bit surprised to find:

� $ ruby -v
� ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

I abandoned it quickly when at least one of my libraries (use) because
of a bug. That, and Rails (for work).

Regards,

Dan


#6

On Nov 26, 5:55 am, Trans removed_email_address@domain.invalid wrote:

I just updated my Ubuntu system and was a bit surprised to find:

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

I abandoned it quickly when at least one of my libraries (use) because
of a bug. That, and Rails (for work).

Regards,

Dan


#7

As you may know Ruby 1.8.7 don’t compatable with Rails(http://
www.rubyonrails.org/down)
We recommend Ruby 1.8.6 for use with Rails. Ruby 1.8.7, 1.8.5, 1.8.4
and 1.8.2 are still usable too, but version 1.8.3 is not.
Ruby 1.8.7 still has some bugs to straighten out.

Step-by-step to downgrade Ruby to 1.8.6 manual
http://railsgeek.com/2008/11/27/ubuntu-8-10-downgrade-ruby-1-8-7-to-1-8-6


#8

Trans wrote:

I just updated my Ubuntu system and was a bit surprised to find:

$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

FWIW, we’ve decided not to support 1.8.7 in JRuby. That may change if
everyone starts depending on 1.8.7-only features, but I sure hope that
doesn’t happen.

  • Charlie

#9

On 27 nov. 08, at 16:27, Anatoly M. wrote:

As you may know Ruby 1.8.7 don’t compatable with
Rails(http://www.rubyonrails.org/down)

Uh, this page explicitely says: “We recommend Ruby 1.8.7 for use
with Rails”.


#10

On Nov 28, 3:36 am, Luc H. removed_email_address@domain.invalid wrote:

On 27 nov. 08, at 16:27, Anatoly M. wrote:

As you may know Ruby 1.8.7 don’t compatable with
Rails(http://www.rubyonrails.org/down)

Uh, this page explicitely says: “We recommend Ruby 1.8.7 for use
with Rails”.

Yay! It’s been fixed. Probably due to this thread.


#11

Put simply: 1.8.7 has features and behavioral changes that are
compatible with neither 1.9 nor 1.8.6. So it’s up to you.


#12

Guys, I am a bit confused :wink: So is it (not) recommended to switch to
1.8.7? I’d like to, but I am not sure after this thread?

Cheers,
Peter


http://www.rubyrailways.com
http://scrubyt.org


#13

Though support was dropped for Ruby <= 1.8.5, 1.8.6 is still
officially supported, AFAIK.

It is indeed officially supported but, judging from the commit logs,
1.8.7 and 1.9 get WAY more attention. If that’s a factor in deciding or
not :slight_smile: ].
-=R


#14

On Wed, Nov 26, 2008 at 9:20 AM, Roger P. removed_email_address@domain.invalid
wrote:

I’ve heard nothing but bad commentary on this version of Ruby. What’s
the word? Should I down-grade?

For better or worse, the 187 branch is basically the only one that gets
any attention from the core developers [i.e. patches] so…I’d say
either one is ok.

Though support was dropped for Ruby <= 1.8.5, 1.8.6 is still
officially supported, AFAIK.

$ ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [i686-darwin9.4.0]

-greg


#15

As they should. The fact that Ruby 1.8.6 is not changing much is a
feature.
Ruby 1.9.1 is being stabilized for its first production ready release,
so it’s no surprise that it is active.

But why should Ruby 1.8.7 be extensively patched? One can only hope
it is to remove all of the 1.8.7-isms and bring it back to
compatibility with Ruby 1.8. :slight_smile:

LOL. Yeah I’m wish you on this one. That is is somewhat annoying to
have to support the new version. To me, though, since I’m interested in
hacking core and getting patches accepted, 1.8.7 is probably a better
bet.

Unfortunately, also, judging from the latest 1.8.7 changelog [1] I’d
wager there are quite a few bugs that get squashed in 1.8.7 but not in
1.8.6, but hopefully they don’t matter :slight_smile:
-=R
[1] http://redmine.ruby-lang.org/repositories/show/ruby-187 at the
bottom


#16

On Wed, Dec 3, 2008 at 12:21 PM, Roger P. removed_email_address@domain.invalid
wrote:

Though support was dropped for Ruby <= 1.8.5, 1.8.6 is still
officially supported, AFAIK.

It is indeed officially supported but, judging from the commit logs,
1.8.7 and 1.9 get WAY more attention. If that’s a factor in deciding or
not :slight_smile: ].

As they should. The fact that Ruby 1.8.6 is not changing much is a
feature.
Ruby 1.9.1 is being stabilized for its first production ready release,
so it’s no surprise that it is active.

But why should Ruby 1.8.7 be extensively patched? One can only hope
it is to remove all of the 1.8.7-isms and bring it back to
compatibility with Ruby 1.8. :slight_smile:

-greg