Thin server giving Stack level too deep error

Hi,

I am using thin web server in my rails project. But it gives stack level
too deep error. Couldn’t find any appropriate solution to this.
I have tried updating the ruby but didn’t help.

Regards,
Sumit

On Thu, Dec 13, 2012 at 1:31 PM, Sumit S. <
[email protected]> wrote:

Hi,

I am using thin web server in my rails project. But it gives stack level
too deep error. Couldn’t find any appropriate solution to this.
I have tried updating the ruby but didn’t help.

can you post the entire trace here? just a quick check would be to
create
a new rails app
using the same version of thin that you’re getting issues with. If it
works, then there’s
something wrong with your config. First thing to look at would be the
initializers you added.
Next would be to look at your environment config.

To view this discussion on the web visit
https://groups.google.com/d/msg/rubyonrails-talk/-/5IEH7kxOki8J.
For more options, visit https://groups.google.com/groups/opt_out.

On 13 December 2012 11:13, Jim Ruther N. [email protected] wrote:

I have tried updating the ruby but didn’t help.

can you post the entire trace here? just a quick check would be to create
a new rails app
using the same version of thin that you’re getting issues with. If it
works, then there’s
something wrong with your config. First thing to look at would be the
initializers you added.
Next would be to look at your environment config.

This is what I get in trace,

HTTP/1.1 500 Internal Server Error
Connection: close
Server: thin 1.3.1 codename Triple Espresso

SystemStackError: stack level too deep

On 13 December 2012 11:17, sumit srivastava
[email protected]wrote:

initializers you added.

The same thing works on some systems while fails on some. Googled about
it
and found several people have been facing this issue with thin. Didn’t
get
any concrete solution.

On 13 December 2012 11:23, Jim Ruther N. [email protected] wrote:

I am using thin web server in my rails project. But it gives stack
Next would be to look at your environment config.

The same thing works on some systems while fails on some. Googled about
it and found several people have been facing this issue with thin. Didn’t
get any concrete solution.

have you tried reinstalling the gem? or using a lower version of the gem?

Yes, I have also mentioned that it works on some systems but creates
problem on few.

On Thu, Dec 13, 2012 at 1:56 PM, sumit srivastava <
[email protected]> wrote:

[email protected]> wrote:

Hi,
something wrong with your config. First thing to look at would be the
SystemStackError: stack level too deep
Yes, I have also mentioned that it works on some systems but creates
problem on few.

Yep, I read that part. Sorry, I don’t have any ideas anymore. Good
luck.

Groups “Ruby on Rails: Talk” group.

[email protected]
[email protected]
For more options, visit https://groups.google.com/groups/opt_out.

On Thu, Dec 13, 2012 at 1:48 PM, sumit srivastava <
[email protected]> wrote:

On Thu, Dec 13, 2012 at 1:31 PM, Sumit S. <
create a new rails app
Connection: close
Server: thin 1.3.1 codename Triple Espresso

SystemStackError: stack level too deep

The same thing works on some systems while fails on some. Googled about it
and found several people have been facing this issue with thin. Didn’t get
any concrete solution.

have you tried reinstalling the gem? or using a lower version of the
gem?

Groups “Ruby on Rails: Talk” group.

[email protected]
To unsubscribe from this group, send email to
[email protected]
For more options, visit https://groups.google.com/groups/opt_out.

On 13 December 2012 12:18, Jim Ruther N. [email protected] wrote:

This is what I get in trace,
get any concrete solution.

Thanks.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs