The vendor dir, gems and openid

Dear all,

I am currently developing an application which uses OpenID as a login
system. On my development box everything works like a charm. But as
soon as I deploy the code to our production server things go wrong.
First the OpenID gem could not be located. This made sense as it is not
installed on the production server, so after some browsing it appeared
that I needed:
$ cd /path/to/railsapp/vendor
$ gem unpack ruby-openid
Added all to SVN and re-deployed.
Still no love. Resulting error:

’ MissingSourceFile
no such file to load – openid’

OK, so apparently that did not work, inspecting my openid_controller.rb
I say that ‘openid’ is only loaded when the require_gem command failed:

require “pathname”
require “cgi”

load the openid library

require “rubygems”
require_gem “ruby-openid”, “>= 1.0.2”
rescue LoadError
require “openid”

I tried ‘require “ruby-openid-1.1.4”’ and ‘require “ruby-openid”’
instead of the require_gem as I read that the method would soon be
deprecated. But still it failed to locate the unpack gem in the vendor
dir. My vendor dir looks as follows:
total 12
drwxrwxr-x 3 harm harm 4096 2007-01-24 21:51 plugins
drwxrwxr-x 6 harm harm 4096 2007-01-24 21:51 ruby-openid-1.1.4
drwxrwxr-x 6 harm harm 4096 2007-01-24 21:51 ruby-yadis-0.3.4

Does anybody see what I am doing wrong?
Any help is greatly appreciated.

With kind regards,