The Rails Server

When i try to run the rails server it tells me i do not have sqlite3-
ruby installed. when i run bundle install (which is the command it
tells me to run) it install some things but then when i try it agian
it does not work still. says its not there again. i even checked the
ubuntu repos and installed the sqlite3-ruby1.9.1 package, wbut that
did not fikx the probrlem. can anyone help my with this?

Am 09.10.2010 um 19:15 schrieb augdawg:

When i try to run the rails server it tells me i do not have sqlite3-
ruby installed. when i run bundle install (which is the command it
tells me to run) it install some things but then when i try it agian
it does not work still. says its not there again. i even checked the
ubuntu repos and installed the sqlite3-ruby1.9.1 package, wbut that
did not fikx the probrlem. can anyone help my with this?

You probably have messed up gem paths, especially if you have some gems
installed as root, others installed as your user, and others still
installed through apt. What does “gem list” return when run as your user
and root? Same thing for “gem environment”.

Best,

Felix

On 10-10-09 01:15 PM, augdawg wrote:

When i try to run the rails server it tells me i do not have sqlite3-
ruby installed. when i run bundle install (which is the command it
tells me to run) it install some things but then when i try it agian
it does not work still. says its not there again. i even checked the
ubuntu repos and installed the sqlite3-ruby1.9.1 package, wbut that
did not fikx the probrlem. can anyone help my with this?

use gem and not a ubuntu package manager to install gem, try

sudo gem install sqlite3-ruby

also this is how you should have installed other gems including rails

sudo gem install rails

if you can’t sudo using your account then try without sudo


Kind Regards,
Rajinder Y.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs