The rails_1_1 branch


#1

Okay, who wants to be on the bleading edge?

If you’ve been watching the typo trac[1], you’ll have seen that we now
have a rails_1_1 branch. If you’ve been watching carefully, you’ll be
aware that we think we’ve ironed out the bugs and it works for both
Rails 1.1 and 1.0 with the following caveat:

  • Under Rails 1.0 it’s a wee bit fragile in development mode; if you
    interrupt a request before it’s finished, you’ll get a white screen
    of death

However, from the testing I’ve managed to give it, it seems to be
reasonably bulletproof under Rails 1.1 in both development and
production mode, and under Rails 1.0 in production mode. Since a lot
of you are using production mode, you probably won’t see the 1.0
problems.

So, before we merge the branch back onto the main line and call it
done, we’d appreciate bug reports and ‘no bug’ reports from as many
people as possible. The magic incantation to run from your typo base
directory is

$ svn switch svn://typosphere.org/typo/branches/rails_1_1

If you don’t have your typo repository under svn control, you can
check it out using:

$ svn co svn://typosphere.org/typo/branches/rails_1_1
<target_directory>

If you’re running Typo 2.6.0, you’ll need to freeze rails 1.0 in your
vendor directory; I’m afraid we’re unlikely to go back and fix it to
work with Rails 1.1, but if anyone has a patch.

  1. http://www.typosphere.org/trac/timeline – a good place to start

#2

Hello all,

This morning I’ve switched on the rails_1_1 branch for my typo blogs
(production & development)

After a restart of my apache server, everything just works perfectly!

Thanks for this great job!

PS:my installation: Apache 2.0.54 on debian Sarge, rails 1.1 :-),
fastcgi
module

Regards Cédric

Le Jeudi 30 Mars 2006 07:01, Piers C. a écrit :


#3

It’s working here. Rails 1.1, ruby 1.8.2 and latest lighttpd.
david richardson–www.channel200.net


#4

Switched yesterday… Works fine under 1.1

On 3/30/06, cedric removed_email_address@domain.invalid wrote:

module

So, before we merge the branch back onto the main line and call it

Jon Gretar B.
http://www.jongretar.net/


#5

Ok, I can report success on Ubuntu Dapper with rails 1.0 and
lighttp,I’ll be giving 1.1 a try later today.
Cheers,Kevin K.On 3/30/06, Jon Gretar B.
removed_email_address@domain.invalid wrote:> Switched yesterday… Works fine
under 1.1>> On 3/30/06, cedric removed_email_address@domain.invalid wrote:> >
Hello all,> >> > This morning I’ve switched on the rails_1_1 branch for
my typo blogs> > (production & development)> >> > After a restart of my
apache server, everything just works perfectly!> >> > Thanks for this
great job!> >> > PS:my installation: Apache 2.0.54 on debian Sarge,
rails 1.1 :-), fastcgi> > module> >> > Regards Cédric> >> > Le Jeudi 30
Mars 2006 07:01, Piers C. a écrit:> > > Okay, who wants to be on the
bleading edge?> > >> > > If you’ve been watching the typo trac[1],
you’ll have seen that we now> > > have a rails_1_1 branch. If you’ve
been watching carefully, you’ll be> > > aware that we think we’ve ironed
out the bugs and it works for both> > > Rails 1.1 and 1.0 with the
following caveat:> > >> > > * Under Rails 1.0 it’s a wee bit fragile in
development mode; if you> > > interrupt a request before it’s
finished, you’ll get a white screen> > > of death> > >> > > However,
from the testing I’ve managed to give it, it seems to be> > > reasonably
bulletproof under Rails 1.1 in both development and> > > production
mode, and under Rails 1.0 in production mode. Since a lot> > > of you
are using production mode, you probably won’t see the 1.0> > >
problems.> > >> > > So, before we merge the branch back onto the main
line and call it> > > done, we’d appreciate bug reports and ‘no bug’
reports from as many> > > people as possible. The magic incantation to
run from your typo base> > > directory is> > >> > > $ svn switch
svn://typosphere.org/typo/branches/rails_1_1> > >> > > If you don’t have
your typo repository under svn control, you can> > > check it out
using:> > >> > > $ svn co svn://typosphere.org/typo/branches/rails_1_1
<target_directory>> > >> > > If you’re running Typo 2.6.0, you’ll need
to freeze rails 1.0 in your> > > vendor directory; I’m afraid we’re
unlikely to go back and fix it to> > > work with Rails 1.1, but if
anyone has a patch.> > >> > > 1. http://www.typosphere.org/trac/timeline
– a good place to start> >> >
_______________________________________________> > Typo-list mailing
list> > removed_email_address@domain.invalid> >
http://rubyforge.org/mailman/listinfo/typo-list> >>>> -->
--------------> Jon Gretar B.> http://www.jongretar.net/>>
_______________________________________________> Typo-list mailing list>
removed_email_address@domain.invalid>
http://rubyforge.org/mailman/listinfo/typo-list>

–Cheers,Kevin K.http://blog.kubasik.net/


#6

Update, works with both 1.1 and 1 (I had no real issues when
tryingdevelopment mode as well)
Cheers,Kevin K.
On 3/30/06, Kevin K. removed_email_address@domain.invalid wrote:> Ok, I can report
success on Ubuntu Dapper with rails 1.0 and lighttp,> I’ll be giving 1.1
a try later today.>> Cheers,> Kevin K.> On 3/30/06, Jon Gretar
Borgthorsson removed_email_address@domain.invalid wrote:> > Switched
yesterday… Works fine under 1.1> >> > On 3/30/06, cedric
removed_email_address@domain.invalid wrote:> > > Hello all,> > >> > > This
morning I’ve switched on the rails_1_1 branch for my typo blogs> > >
(production & development)> > >> > > After a restart of my apache
server, everything just works perfectly!> > >> > > Thanks for this great
job!> > >> > > PS:my installation: Apache 2.0.54 on debian Sarge, rails
1.1 :-), fastcgi> > > module> > >> > > Regards Cédric> > >> > > Le Jeudi
30 Mars 2006 07:01, Piers C. a écrit:> > > > Okay, who wants to be
on the bleading edge?> > > >> > > > If you’ve been watching the typo
trac[1], you’ll have seen that we now> > > > have a rails_1_1 branch. If
you’ve been watching carefully, you’ll be> > > > aware that we think
we’ve ironed out the bugs and it works for both> > > > Rails 1.1 and 1.0
with the following caveat:> > > >> > > > * Under Rails 1.0 it’s a wee
bit fragile in development mode; if you> > > > interrupt a request
before it’s finished, you’ll get a white screen> > > > of death> > >

However, from the testing I’ve managed to give it, it seems to
be> > > > reasonably bulletproof under Rails 1.1 in both development
and> > > > production mode, and under Rails 1.0 in production mode.
Since a lot> > > > of you are using production mode, you probably won’t
see the 1.0> > > > problems.> > > >> > > > So, before we merge the
branch back onto the main line and call it> > > > done, we’d appreciate
bug reports and ‘no bug’ reports from as many> > > > people as possible.
The magic incantation to run from your typo base> > > > directory is> >

$ svn switch svn://typosphere.org/typo/branches/rails_1_1>

If you don’t have your typo repository under svn control,
you can> > > > check it out using:> > > >> > > > $ svn co
svn://typosphere.org/typo/branches/rails_1_1 <target_directory>> > > >>

If you’re running Typo 2.6.0, you’ll need to freeze rails 1.0 in
your> > > > vendor directory; I’m afraid we’re unlikely to go back and
fix it to> > > > work with Rails 1.1, but if anyone has a patch.> > > >>

  1. http://www.typosphere.org/trac/timeline – a good place to
    start> > >> > > _______________________________________________> > >
    Typo-list mailing list> > > removed_email_address@domain.invalid> > >
    http://rubyforge.org/mailman/listinfo/typo-list> > >> >> >> > --> >
    --------------> > Jon Gretar B.> > http://www.jongretar.net/>

_______________________________________________> > Typo-list
mailing list> > removed_email_address@domain.invalid> >
http://rubyforge.org/mailman/listinfo/typo-list> >>>> --> Cheers,> Kevin
Kubasik> http://blog.kubasik.net/>

–Cheers,Kevin K.http://blog.kubasik.net/


#7

Sorry, some of that seems to have been leftover processes, oops…
A proper restart reveils a small issue under 1.1 with the content admin
pages:
Processing ContentController#index (for 205.222.248.25 at
2006-03-3007:55:13) [GET] Session ID: 7e020172db947e7eee8a3e5e635317e3
Parameters: {“action”=>“index”, “controller”=>“admin/content”}Rendering
admin/content/list within layouts/administrationRendering
admin/content/list

NoMethodError (undefined method controller_name' for nil:NilClass): /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:541:incallback’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:534:inafter' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:227:inaround_filter’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:388:incall_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:381:incall_filters’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:376:inafter_action' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:356:inperform_action_without_benchmark’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/rescue.rb:82:inperform_action’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/base.rb:379:inprocess_without_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:364:inprocess_without_session_management_support’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/session_management.rb:117:inprocess' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/dispatcher.rb:38:indispatch’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:150:inprocess_request' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:54:inprocess!’ /usr/lib/ruby/1.8/fcgi.rb:600:in each_cgi' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:53:in
process!' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:23:inprocess!’ /public/dispatch.fcgi:24

On 3/30/06, Kevin K. removed_email_address@domain.invalid wrote:> Update, works with
both 1.1 and 1 (I had no real issues when trying> development mode as
well)>> Cheers,> Kevin K.>> On 3/30/06, Kevin K.
removed_email_address@domain.invalid wrote:> > Ok, I can report success on Ubuntu Dapper
with rails 1.0 and lighttp,> > I’ll be giving 1.1 a try later today.> >>

Cheers,> > Kevin K.> > On 3/30/06, Jon Gretar B.
removed_email_address@domain.invalid wrote:> > > Switched yesterday… Works
fine under 1.1> > >> > > On 3/30/06, cedric
removed_email_address@domain.invalid wrote:> > > > Hello all,> > > >> > > >
This morning I’ve switched on the rails_1_1 branch for my typo blogs> >

(production & development)> > > >> > > > After a restart of my
apache server, everything just works perfectly!> > > >> > > > Thanks for
this great job!> > > >> > > > PS:my installation: Apache 2.0.54 on
debian Sarge, rails 1.1 :-), fastcgi> > > > module> > > >> > > > Regards
Cédric> > > >> > > > Le Jeudi 30 Mars 2006 07:01, Piers C. a écrit:>

Okay, who wants to be on the bleading edge?> > > > >> > > > > If
you’ve been watching the typo trac[1], you’ll have seen that we now> > >

have a rails_1_1 branch. If you’ve been watching carefully, you’ll
be> > > > > aware that we think we’ve ironed out the bugs and it works
for both> > > > > Rails 1.1 and 1.0 with the following caveat:> > > > >>

  • Under Rails 1.0 it’s a wee bit fragile in development mode; if
    you> > > > > interrupt a request before it’s finished, you’ll get a
    white screen> > > > > of death> > > > >> > > > > However, from the
    testing I’ve managed to give it, it seems to be> > > > > reasonably
    bulletproof under Rails 1.1 in both development and> > > > > production
    mode, and under Rails 1.0 in production mode. Since a lot> > > > > of
    you are using production mode, you probably won’t see the 1.0> > > > >
    problems.> > > > >> > > > > So, before we merge the branch back onto the
    main line and call it> > > > > done, we’d appreciate bug reports and ‘no
    bug’ reports from as many> > > > > people as possible. The magic
    incantation to run from your typo base> > > > > directory is> > > > >> >

$ svn switch svn://typosphere.org/typo/branches/rails_1_1> > > >

If you don’t have your typo repository under svn control, you
can> > > > > check it out using:> > > > >> > > > > $ svn co
svn://typosphere.org/typo/branches/rails_1_1 <target_directory>> > > >

If you’re running Typo 2.6.0, you’ll need to freeze rails 1.0
in your> > > > > vendor directory; I’m afraid we’re unlikely to go back
and fix it to> > > > > work with Rails 1.1, but if anyone has a patch.>

  1. http://www.typosphere.org/trac/timeline – a good
    place to start> > > >> > > >
    _______________________________________________> > > > Typo-list mailing
    list> > > > removed_email_address@domain.invalid> > > >
    http://rubyforge.org/mailman/listinfo/typo-list> > > >> > >> > >> > >
    –> > > --------------> > > Jon Gretar B.> > >
    http://www.jongretar.net/> > >> > >
    _______________________________________________> > > Typo-list mailing
    list> > > removed_email_address@domain.invalid> > >
    http://rubyforge.org/mailman/listinfo/typo-list> > >> >> >> > --> >
    Cheers,> > Kevin K.> > http://blog.kubasik.net/> >>>> --> Cheers,>
    Kevin K.> http://blog.kubasik.net/>

–Cheers,Kevin K.http://blog.kubasik.net/


#8

“Kevin K.” removed_email_address@domain.invalid writes:

Sorry, some of that seems to have been leftover processes, oops…
A proper restart reveils a small issue under 1.1 with the content
admin pages:

Kevin, please format your mail to around an 80 column line
wrap. Your mail is the next best thing to unreadable.


#9

My most sincere apologies, that last one was sent over a
remoteconnection, I hope this has fixed it.
Processing ContentController#index (for 205.222.248.25 at
2006-03-3007:55:13) [GET] Session ID: 7e020172db947e7eee8a3e5e635317e3
Parameters: {“action”=>“index”, “controller”=>“admin/content”}Rendering
admin/content/list within layouts/administrationRendering
admin/content/list

NoMethodError (undefined method controller_name' for nil:NilClass): /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:541:incallback’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:534:inafter' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:227:inaround_filter’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:388:incall_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:381:incall_filters’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:376:inafter_action' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:356:inperform_action_without_benchmark’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’ /usr/lib/ruby/gems/1.!
8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:inperform_action_without_rescue' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/rescue.rb:82:inperform_action’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/base.rb:379:inprocess_without_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:364:inprocess_without_session_management_support’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/session_management.rb:117:inprocess' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/dispatcher.rb:38:indispatch’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:150:inprocess_request' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:54:inprocess!’ /usr/lib/ruby/1.8/fcgi.rb:600:in each_cgi' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:53:in
process!' /usr/lib/ruby/gems/1.8! /gems/rails-1.1.0/lib/fcgi_handler.rb:23:inprocess!’
/public/dispatch.fcgi:24

On 3/30/06, Piers C. removed_email_address@domain.invalid wrote:> “Kevin K.”
removed_email_address@domain.invalid writes:>> > Sorry, some of that seems to have been
leftover processes, oops…> > A proper restart reveils a small issue
under 1.1 with the content> > admin pages:>> Kevin, please format your
mail to around an 80 column line> wrap. Your mail is the next best thing
to unreadable.>> --> Piers C. removed_email_address@domain.invalid>
http://www.bofh.org.uk/>
_______________________________________________> Typo-list mailing list>
removed_email_address@domain.invalid>
http://rubyforge.org/mailman/listinfo/typo-list>

–Cheers,Kevin K.http://blog.kubasik.net/


#10

“Kevin K.” removed_email_address@domain.invalid writes:

My most sincere apologies, that last one was sent over a
remoteconnection, I hope this has fixed it.

Nope.


#11

Piers C. wrote:

Okay, who wants to be on the bleading edge?

Well after a bit of grief with forcing Rails to use the production
environment after the Rails upgrade I have gotten this to work, for the
most part it works fine but the AJAX commenting does something weird
with the sidebar and makes it repeat on the other side at the bottom.

If you leave a comment on one of my posts at
http://typo.jasonbainbridge.com then you’ll see what I mean, is that
just a theme related issue or something within typo?

Regards,
Jason


#12

I had the same thing happening to me. In
app/controllers/articles_controller.rb change

layout :theme_layout, :except => [:comment_preview, :trackback]
to
layout :theme_layout, :except => [:comment, :comment_preview,
:trackback]


#13

Jason B. removed_email_address@domain.invalid writes:

bottom.
How peculiar.

If you leave a comment on one of my posts at
http://typo.jasonbainbridge.com then you’ll see what I mean, is that
just a theme related issue or something within typo?

I think it’s the theme. It doesn’t seem to be replicated here, using
the Azure theme.


#14

“Dean S.” removed_email_address@domain.invalid writes:

I had the same thing happening to me. In
app/controllers/articles_controller.rb change

layout :theme_layout, :except => [:comment_preview, :trackback]
to
layout :theme_layout, :except => [:comment, :comment_preview,
:trackback]

Not necessarily a good fix. Rendering a partial (which is what we do
for ajax comment additions) shouldn’t use the layout anyway. And for
none ajax comments you need to render with the layout.


#15

I’m sorry again, I feel really dumb, here it is with html formatting
(I’m
using Gmail, apperently it doesn’t handle the line formatting well :-/)

Processing ContentController#index (for 205.222.248.25 at 2006-03-30
07:55:13) [GET]
Session ID: 7e020172db947e7eee8a3e5e635317e3
Parameters: {“action”=>“index”, “controller”=>“admin/content”}
Rendering admin/content/list within layouts/administration
Rendering admin/content/list

NoMethodError (undefined method controller_name' for nil:NilClass): /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/caching.rb:541:incallback’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/caching.rb:534:in
after' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/filters.rb:227:inaround_filter’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/filters.rb:388:in
call_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/filters.rb:381:incall_filters’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/filters.rb:376:in
after_action' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/filters.rb:356:inperform_action_without_benchmark’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/benchmarking.rb:69:in
perform_action_without_rescue' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/rescue.rb:82:inperform_action’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/base.rb:379:in
process_without_filters' /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/filters.rb:364:inprocess_without_session_management_support’
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0
/lib/action_controller/session_management.rb:117:in
process' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/dispatcher.rb:38:indispatch’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:150:in
process_request' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:54:inprocess!’
/usr/lib/ruby/1.8/fcgi.rb:600:in each_cgi' /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:53:in
process!' /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:23:inprocess!’
/public/dispatch.fcgi:24

Cheers,
Kevin K.


#16

oops, a few minutes behind this one… works for me now.
Again, many thanksOn 3/30/06, Kevin K. removed_email_address@domain.invalid
wrote:>>> I’m sorry again, I feel really dumb, here it is with html
formatting (I’m using Gmail, apperently it doesn’t handle the line
formatting well :-/)>>> Processing ContentController#index (for
205.222.248.25 at 2006-03-30> 07:55:13) [GET]> Session ID:
7e020172db947e7eee8a3e5e635317e3> Parameters: {“action”=>“index”,
“controller”=>“admin/content”}> Rendering admin/content/list within
layouts/administration> Rendering admin/content/list>>> NoMethodError
(undefined method controller_name' for nil:NilClass):> /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:541:in>callback’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:534:in>
after'> /usr/lib/ruby/gems/1.8/gems/actionpack- 1.12.0/lib/action_controller/filters.rb:227:in>around_filter’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:388:in>
call_filt! ers'> /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0 /lib/action_controller/filters.rb:381:in>call_filters’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:376:in>
after_action'> /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:356:in>perform_action_without_benchmark’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:in>
perform_action_without_rescue'> /usr/lib/ruby/1.8/benchmark.rb:293:inmeasure’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:in>
perform_action_without_rescue'> /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/rescue.rb:82:in>perform_action’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/base.rb:379:in>
process_without_filters'> /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:364:in>process_without_session_management_s!
upport’>
/usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/session_management.rb:117:in>
process'> /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/dispatcher.rb:38:indispatch’>
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:150:in>
process_request'> /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:54:inprocess!’> /usr/lib/ruby/1.8/fcgi.rb:600:in each_cgi'> /usr/lib/ruby/1.8/fcgi.rb:597:ineach_cgi’>
/usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:53:in
process!'> /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:23:inprocess!’> /public/dispatch.fcgi:24>>>> Cheers,> Kevin K.>>> On
3/30/06, Piers C. removed_email_address@domain.invalid wrote:> > “Dean S.”
<removed_email_address@domain.invalid > writes:> >> > > I had the same thing happening to
me. In> > > app/controllers/articles_controller.rb change> > >> > >
layout :theme_layout, :except => [:comment_preview, :trackback]> > > to>

layout :theme_layout!
, :except => [:comment, :comment_preview,> > > :trackback]> >> > Not
necessarily a good fix. Rendering a partial (which is what we do> > for
ajax comment additions) shouldn’t use the layout anyway. And for> > none
ajax comments you need to render with the layout.> >> > --> > Piers
Cawley removed_email_address@domain.invalid> > http://www.bofh.org.uk/> >
_______________________________________________> > Typo-list mailing
list> > removed_email_address@domain.invalid> >
http://rubyforge.org/mailman/listinfo/typo-list> >>>>> -->> Cheers,>
Kevin K.> http://blog.kubasik.net/>>

–Cheers,Kevin K.http://blog.kubasik.net/


#17

Not necessarily a good fix. Rendering a partial (which is what we do
for ajax comment additions) shouldn’t use the layout anyway. And for
none ajax comments you need to render with the layout.

Yeow. Sorry! Well, it worked fto get comments functioning correctly
again with me, and I’ve got non-AJAX layouts disabled anyway. Well,
proceed with caution, I suppose.


#18

“Kevin K.” removed_email_address@domain.invalid writes:

oops, a few minutes behind this one… works for me now.

Yup. Someone on IRC had the same problem and we tracked it down.

Since gmail does such a lousy job with trackbacks, you might be best
served in future by dumping the error output in the pastebin
(http://rafb.net/paste) and simply pasting the resulting url into your
message.