The module build is not compatible with the host code build

hi all,

i am running the tx_waveforms example on the usrp E100 but i got the
following error

Expected module compatibility number 0x3, but got 0xffffffff
The module build is not compatible with the host code build.

my uhd version is UHD_003.004.000-5b06adb
i got the fpga image from the tar file of the 003.004 image from the
recent images link but it didn’t work,also 0xffffffff seems strange all
problems on the forums vary between 0x1 and 0x2
how i can i know the compatibility code of the image and where i can get
the 0x3 compatibility image

any help would be appreciated

On Mon, 6 Feb 2012 16:39:24 +0000, osama mohamed wrote:

hi
all,

i am running the tx_waveforms example on the usrp E100 but i
got the following error

Expected module compatibility number 0x3,
but got 0xffffffff
The module BUILD IS NOT COMPATIBLE WITH THE HOST
CODE BUILD.

my uhd version is UHD_003.004.000-5b06adb
i got the
fpga image from the tar file of the 003.004 image from the recent images
link but it didn’t work,also 0xffffffff seems strange all problems on
the forums vary between 0x1 and 0x2
how i can i know the compatibility
code of the image and where i can get the 0x3 compatibility image

any help would be appreciated

You probably didn’t burn the image
correctly into the target device.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs