The {{key}} interpolation syntax in I18n messages is deprecated

All,
Has anyone seen this - I am getting the following deprecation warning
when
running my functional tests under rails 2.3.8 (just moved an app from
2.3.4
up to 2.3.8 in prep to move to Rails 3 — if you think this problem is
solved in Rails 3 then let me know):

The {{key}} interpolation syntax in I18n messages is deprecated. Please
use
%{key} instead.

I have isolated the problem to the following line in my model — when I
do
not add this error everything is fine:

errors.add_to_base(“Uploaded file must be present”) if
!self.uploaded_file_content

Also tried this but same result:

errors.add(:uploaded_file_content, “Uploaded file must be present”) if
!self.uploaded_file_content

The irony is on this app I have no use for i18n. Would be also just as
glad
to turn it off, but of course that would only be a band-aid.

Thanks in advance!

David

Please disregard this post. I just switched to using rvm, and seems that
the
issue auto-corrected.

Also interestingly, my tests sped up, taking less than 30% of the time
they
used to take (units used to take 90 seconds, now 23 seconds). Not sure
if
this is due to using a slightly higher build number of ruby or to credit
rvm. Either way, nice surprise.

I noticed that error message when using the i18n gem instead of Rails’
default i18n. Could that have been the issue?

I seem to have obliterated my previous install of Ruby while installing
rvm
so I will never know. But I am so happy with rvm that I am overlooking
this
mishap. At least I was not consciously using the i18n gem if this was
the
case.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs