Textfilter error in SVN v1219

I upgraded last week to Rails 1.1.6 because of all the security warnings
and
it has worked OK on my blog running v1004.
So, I thought now might be the time to move to a new typo version.
On a test server with a clone of my production database, I did “svn
update”
to bring me to v1219 since I want something v4.0.X.
I also did the “rake migrate RAILS_ENV=production” which worked
flawlessly.
I restarted the server having made sure all old fcgi’s were gone in
between
stop and start.
I’m using Azure to be most compatible, but Scribbish also sees the same
issue.
I still haven’t gotten to a 4.0.X version that is completely clean for
me.
But these two seem to be the last issues…

When I then authenticate into blog/admin, I get the following. Is there
possibly a gem that might be missing or something known not to migrate
from

ActionView::TemplateError (uninitialized constant
Admin::BaseHelper::TextFilter) on line #125 of
app/views/admin/general/index.rhtml:
122:

Typo supports a number of text filtering
options. To add new filters, see the “filters” tab on the toolbar
above.


123:


124:
125: <%= options_for_select text_filter_options,
TextFilter.find_by_name(this_blog.text_filter) %>
126:
127: Article filter
128:

Also, there is an article that I can view in a catagory…
http://www.swordcery.com/blog/articles/tag/halo
but not as an individual article…

http://www.swordcery.com/blog/articles/2006/08/13/how-to-mod-halo-pc-beginner-level-2
and no error is produced for that last one. The sidebars and rest are
displayed OK.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs