Testing FLEX modems with gnuradio

I am new to gnuradio and have spent the last few days reading every
tutorial I can find. I have set up both 3.7.1 and 3.6.5 in separate
test
environments in 2 VMs. I am using a BladeRF SDR with dual 900MHz
antenna.

I’ve been asked to test 2 devices which will controlled remotely over
the
FLEX paging network. I can see some blocks have been built into
gnuradio-companion, FLEX Deinterleave and FLEX Synchronizer. I also
found
some samples here https://github.com/argilo/sdr-examples but I think
these
were built for a different version of gnuradio possibly. When I run the
python script pager_rx.py or pager_rx_929.py it pops up with a nice
waterfall display and I even get some text decoded signals in the
terminal
window, but within a few seconds the display goes gray and I cannot
change
any of the sliders and must force quit to get out. I loaded the
multi_tx.grc in gnuradio-companion just to get an idea of how to build a
flow chart for FLEX, but I get some errors about missing blocks.

Loading: “/home/test/sandbox/gnuradio-builds/sdr-examples/multi_tx.grc”

Error: Block key “iqbalance_fix_cc” not found in Platform - grc(GNU
Radio Companion)

Error: Connection between blocks_add_xx_0(0) and iqbalance_fix_cc_0(0)
could not be made.
sink block id “iqbalance_fix_cc_0” not in block ids

Error: Connection between iqbalance_fix_cc_0(0) and
blocks_add_const_vxx_1(0) could not be made.
source block id “iqbalance_fix_cc_0” not in block ids

Done

If I’m going to build my own flowcharts, I’ll need to know what the
blocks
in the existing flows are doing, but I haven’t seen any good resources
for
that. If I can get some of the existing scripts to run properly that
might
help as well. Any suggestions on that? Here is the output when I run
the
pager_rx.py

gr-osmosdr v0.1.0-66-g154c4ddd (0.1.1git) gnuradio 3.7.1
built-in source types: file fcd rtl_tcp bladerf rfspace
[bladeRF source] Using nuand LLC bladeRF #0 SN 909d…c10c FW v1.6.1
FPGA
v0.0.2

According to the readme this script is meant to be used with an RTL-SDR
rather than my BladeRF but it seems to detect the blade and I don’t see
any
hardware specific modules being imported. Am I missing something?

Clayton’s sdr-examples are for GnuRadio 3.7.1. Your
issue is that you haven’t built gr-iqbal. It’s not really
needed, so you can just delete that block in the
graphs.

Ron

I’ve tried pager_rx.py on bladeRF, and it works fine
here (GnuRadio 3.7.2.1 and Ubuntu 13.04). Tons of
traffic on channel 25 here in Silicon Valley.

I’ve made some changes to the code to work better
with bladeRF (mostly with the gain setting).

http://www.w6rz.net/pager_rx.py

When a flow grays out and you have to force a
quit, it usually means you don’t have enough CPU cycles.
However, at 1.2 Msps, pager_rx.py isn’t really taking
much CPU. Perhaps it’s your VM?

Ron

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs