Test_usrp_standard_tx, tx_underrun

Hi list,

I have recently begun to see a lot of tx_underrun in my applications. At
first I thought it was due to me not setting realtime- scheduling
properly (which I did), then I thought it might have something to do
with recent fusb_* updates from gnuradio (which it didn’t, since I
downgraded to svn10527 (I did use svn10537) which used to did work).
Then I thought it had something to do with me running to many other
processes on the host computer, but that turned out to not make any
changes either, since I closed all “unnecessary” processes (including
gdm, Xorg and so forth). Then I thought it might have something to do
with Dell cheeping out on the usb-2.0 ports, so I tried switching
between the four of them between tests, but no luck there either…

To check for the underruns I use
“~/gnuradio/usrp/host/apps/test_usrp_standard_tx” (I tried it several
times both as root and as user)
which is reporting ~40 underruns, and a throughput of about 29-30mb/s.

On the other hand, when I’m trying “test_usrp_standard_rx” it reports 0
underruns and 32Mb/s throughput.

The peculiar thing is that code that is running fine on a Dell latitude
e6400 with Ubuntu 8.10 and gnuradio svn10527 isn’t running fine on a
Dell latitude D630 running Ubuntu 8.10 and gnuradio svn10527. I know the
Latitude e6400 should be a more “manly machine”, but I think the D630
should be able to handle “test_usrp_standard_tx” should it not? It has
done so before at least…

I guess my question is, -“Is there anyone who has any clue why I see
these underruns, and/or what I can try to make them go away?”

Best regards
//Mattias K.

Hi again,

Seems like the answer was coming in as I wrote the answer… My cpu-

//Mattias K.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs