Test_usrp_standard_tx Could not set frequency

Hello,

I am new to the GNU Radio. I have been following the steps outlined in
http://gnuradio.org/trac/wiki/UbuntuInstall, and I am at the point where
I am testing.
The command:
ls -lR /dev/bus/usb | grep usrp
shows a single USRP, which is correct.

usrp_benchmark_usb.py
Passes everything but the 32 Mb/s test.

But when I try to run:
test_usrp_standard_tx
I receive this output:

which: 0
interp: 16
rf_freq: -1
amp: 10000.000000
nsamples: 3.2e+07
Subdevice name is XCVR2450 Tx
Subdevice freq range: (2.4e+09, 6e+09)
mux: 0x000089
baseband rate: 8e+06
Fail 4200000000.000000
terminate called after throwing an instance of ‘std::runtime_error’
what(): Could not set frequency.
Aborted

This is on a USRP, with two XCVR2450 daughterboards. I looked through
the wiki, mailinglist, and the web, but I did not find anyone who had
this problem.

Thank you for your help,
Brian Proulx

On Mon, Sep 07, 2009 at 03:39:33PM -0500, [email protected] wrote:

But when I try to run:
mux: 0x000089
Brian Proulx
The XCVR2450 covers 2.4-2.5 GHz and 4.9 to 5.85 GHz. Try tuning to
something in these ranges.

Eric

Thanks for your patience with me. Setting it to 2.41GHz worked.

–Brian

---- Original message ----

On Wed, Sep 09, 2009 at 12:35:21PM -0500, [email protected] wrote:

Thanks for your patience with me. Setting it to 2.41GHz worked.

Glad to hear that it worked!

Eric

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs