Test-unit not found by Ruby but available in gem list

Hi All,

When I include “gem ‘test-unit’” in my ruby file, it gives the following
error. However my “gem list” does show test-unit. I am not sure what is
missing when running the file as “ruby ci_reporter.rb”. The actual ruby
file is attached.

C:\Ruby_Scripts>ruby ci_report.rb
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
to_specs': Could not find test-unit (>= 0) amongst [b igdecimal-1.1.0, childprocess-0.3.1, ffi-1.0.11, io-console-0.3, json-1.5.4, minitest-2.5.1, multi_json-1.1.0, rake-0.9. 2.2, rdoc-3.9.4, rubyzip-0.9.6.1, selenium-webdriver-2.20.0, watir-webdriver-0.5.3] (Gem::LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:into_spec’
from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems.rb:1208:in
gem' from ci_report.rb:1:in

C:\Ruby_Scripts>gem list

*** LOCAL GEMS ***

builder (3.0.0)
childprocess (0.3.1)
ci_reporter (1.7.0)
ffi (1.0.11 java)
jruby-win32ole (0.8.5)
json (1.6.5 java)
multi_json (1.1.0)
rake (0.8.7)
rubygems-update (1.8.17)
rubyzip (0.9.6.1)
selenium-webdriver (2.20.0)
sources (0.0.1)
test-unit (2.4.8)
watir-webdriver (0.5.3)

Installed the same in another machine, and it worked. Looks like the
problem is due to installation of jruby. I have no clue of how they are
related, but the problem is solved for now.

Some gems are special. Their name is not what you have to require.
This is usually only the case with gems that contain a - in their
name. Such as ‘test-unit’. When this happens you should consult
the gem’s documentation. For example, you should require ‘test-unit’
as ‘test/unit’.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs