Template is missing error


#1

Hello! I’m getting a ‘Template is missing’ error that says:

Missing template ./script/…/config/…/app/views/faq/list.rhtml

but there is a blank list.rtml file there. It shows up as a text
document, I don’t know if that matters.

Thanks!


#2

That do you mean it shows up as a text document? Does it have a .txt
extension? If so, that is your problem. It should be called just
list.rhtml.

If that wasn’t helpful, perhaps provide some more information and
someone can be of some help.

Tom


#3

I notice a spelling mistake. Perhaps it is in your email or your
file name. Your file name would explain the problem. Note

Missing template ./script/…/config/…/app/views/faq/list.rhtml

but there is a blank list.rtml file

You are missing an h between the r and t of rtml file.


#4

If so, how would I get Notepad to save as a .rhtml?

Its got to list.rhtml … and while saving save it in quotes " " …if
notepad gives that error…i dont know…i never used notepad much.but i
see
that in many windows apps


#5

Mark removed_email_address@domain.invalid wrote:

Good eye! But it was just a typo in the post. I checked; it’s right on
my computer.

Also, to atomgiant, I’m not sure if it’s list.rhtml or list.rhtml.txt
because I used notepad and I think it does that sometimes. When I check
properties, though, it calls it a Text Document. Maybe this is the
problem.

To save this kind of confusion, configure Windows Explorer to always
display file suffixes. In Windows Explorer, Tools menu, choose “Folder
Options…”, then choose the View tab, then uncheck “Hide extensions for
known file types” and click OK.

If so, how would I get Notepad to save as a .rhtml?

In Notepad’s Save dialog, choose “All Files” in the “Save as type:”
dropdown.

regards

Justin


#6

Good eye! But it was just a typo in the post. I checked; it’s right on
my computer.

Also, to atomgiant, I’m not sure if it’s list.rhtml or list.rhtml.txt
because I used notepad and I think it does that sometimes. When I check
properties, though, it calls it a Text Document. Maybe this is the
problem.

If so, how would I get Notepad to save as a .rhtml?


#7

justin wrote:

In Notepad’s Save dialog, choose “All Files” in the “Save as type:”
dropdown.

It worked! Sorry it took so long to post back. You were completely and
totally right!!

Thanks a ton to everyone who posted so kindly!

Appreciatively,
Mark