Templat rails : option -m sous Linux?

bonjour,

je me demandais comment faire pour créer une application rails avec un
template sous ubuntu dans la mesure ou l’option ‘-m template.rb’ ne
fonctionne pas.
Sous Windows, aucun problème! Elle est prise en compte mais sous Linux
j’obtiens :

[email protected]:~/Bureau/test$ rails essai -d mysql -m
template.rb
getopt : option invalide – m
Terminating…

Je ne sais pas si j’ai mal lu le tutoriel (
http://www.bounga.org/post/2009/01/30/Rails-Templates) mais à aucun
moment on ne parle d’option particulière sous Linux ? Le -m devrait bien
fonctionner ? J’ai tenté sans le tiret mais j’obtiens deux applications
rails : essai et m!

Comment faire ?

Babiben ***** a écrit :

template.rb

Lancer le template sur un linux, pusher ce qui est généré sur un système
de versionning. Récupérer du système de version sur windows.


Cyril M.
http://blog.shingara.fr

Bonjour,
Un détail bête mais on ne sais jamais tu peux faire un rails --version
sous
ton linux ? c’est quoi la réponse

Le 23 juillet 2009 16:26, Cyril M. [email protected] a écrit
:

En fait, actuellement, j’ai fait un “apt-get install rails” et il m’
installé une version 2.0.2. Si je lance rails exemple -d mysql, cela
fonctionne.

J’ai fait cela car j’ai bien installé rails en utilisant les paquets gem
et la commande gem install rails mais si je souhaite voir la version, il
me dit qu’il n’est pas installé. Par contre, si je fais un gem list, il
apparait bien en version 2.3.3! Je ne comprends plus trop le rapport
entre ces deux rails ?

Cependant, je ne peux toujours pas appliquer mon template avec l’option
“-m” avec cette version 2.0.2 ce qui semble logique!! Mais comment
utiliser la version 2.3.3 ?

Bonjour,
Je te conseil de trouver une documentation sur comment installer rails
sur
ubuntu.

Le package debian doit être dépendant du système, tu installe une
version
gem qui ne doit pas être dans le path ou quelque chose comme ça.

Sur Debian et Ubuntu il me semble plus prudent de ne pas tenir compte
des
packages de la distribution mais d’utiliser le package gem, c’est plus
simple pour suivre les mises à jour (surtout sur debian).

Le 24 juillet 2009 11:59, Babiben ***** [email protected] a
écrit :

oui merci bien. J’ai suivi l’installation qui se trouve à l’adresse :
http://www.jaredlog.com/?p=1045 Tout s’est bien passé et plus aucun
problème.

problème résolu.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs