TCP: time wait bucket table overflow

I am just going to pop-up this question. My nginx was doing about 10%
cpu load and I was getting:

May 24 15:58:43 yasmin kernel: [ 983.444403] TCP: time wait bucket
table overflow

I know I can fine-tune my /proc/sys/net/ipv4/tcp_max_tw_buckets and some
other stuff. But I am pretty sure somebody here has more experience with
tcp tuning.

What are good Linux kernel settings for a proxy_pass / load balancer
nginx server?

Some URL’s to background articles would be nice.

In my configuration it passes everything to Apache servers as back-ends.

Thanks in advance,

Kind regards,

Jelle de Jong

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs