Tagged File Sink in GRC

I compiled GNURadio using the build script yesterday. In a previous
version of GNURadio, I believe that the Tagged File Sink was displayed
in GNURadio Companion under sinks. I couldn’t find it there so I search
the build folder as well as my filesystem to find that I had no
gr_tagged_file_sink.xml . I’m not sure if this is an error pertaining
only to my installation or if this was removed from GNURadio at some
point. I do have .cc .o .h ad .i files for gr_tagged_file_sink. I found
the xml file here
and copied it (as root) to /usr/local/share/gnuradio/grc/blocks. It
still isn’t showing up in GRC though. Any idea what I need to do to get
this block showing in GRC? Thanks!


Sorry for the quick response, but I tried opening GRC using the terminal
and got the error below. Any ideas?

On Thu, Jul 26, 2012 at 2:08 PM, Daniel Labarowski
[email protected] wrote:

I actually posted about the warning a little while ago. This was the
response from Tom:

That was due to me forgetting to “git add” the file when we pushed the
rest. I actually noticed this just yesterday but hadn’t been able to
do anything about until I got off the plane just now.

The current versions of master and next should have this fixed.

I re ran the build-gnuradio script and it solved the warning, but I do
not know about the tagged_file_sink error. Maybe it will reinstall the
tagged_file_sink for you. Re-running the script creates extra folders
though. For example, uhd.20120726103430 looks like a copy made at
2012/07/26. Do you know if we can delete these extra folders?

Hope this helps,


Hi guys,

i have the samo proble, can’t find taffed file sink in my GRC. Any
so far?

Thanks and regards

View this message in context:
Sent from the GnuRadio mailing list archive at Nabble.com.

Looks like the Tagged FIle SInk was not fixed in the new update. I’m
certain that those new folders that appeared are the updated git pulls.
hold roughly the same content as the other folders. I guess if you
the script in the same directory, it will make a new folder for the
gits. Gnuradio, uhd, osmosdr, and rtl all had new folders for me but uhd
and grextras must not have updated. Technically you can delete all of
files after install. I like to keep a set around so that I can search
source though. You don’t need both copies - delete the old ones. Any way
can get Tagged FIle Sink working manually?