Syntax error when running dispatch.cgi


#1

Hi,

when I execute dispatch.cgi at the command line, I get the following
error message:

[cg@cg rails]$ ./public/dispatch.cgi
./public/dispatch.cgi:3:in `require’:
./public/…/config/environment.rb:8: syntax error, unexpected ‘<’
(SyntaxError)
<%= '# ’ if freeze %>RAILS_GEM_VERSION = ‘<%= Rails::VERSION::STRING %>’
^ from ./public/dispatch.cgi:3
[cg@cg rails]$

I was asked to install Ruby on Rails on a web server but I don’t know
anything about ruby (…), so I’m not sure what it’s complaining about.

cg.


#2

Carsten Gaebler wrote:

<%= '# ’ if freeze %>RAILS_GEM_VERSION = ‘<%= Rails::VERSION::STRING %>’
^ from ./public/dispatch.cgi:3

What are the contents of your config/environment.rb? Sounds like maybe
its got screwed somehow?

Mine has no ‘<%=’ in it at all.


#3

Hates_ wrote:

What are the contents of your config/environment.rb? Sounds like maybe
its got screwed somehow?

[cg@cg config]$ cat environment.rb

Be sure to restart your web server when you modify this file.

Uncomment below to force Rails into production mode when

you don’t control web/app server and can’t set it the proper way

ENV[‘RAILS_ENV’] ||= ‘production’

Specifies gem version of Rails to use when vendor/rails is not present

<%= '# ’ if freeze %>RAILS_GEM_VERSION = ‘<%= Rails::VERSION::STRING %>’

Bootstrap the Rails environment, frameworks, and default configuration

require File.join(File.dirname(FILE), ‘boot’)

Rails::Initializer.run do |config|

Settings in config/environments/* take precedence those specified

here

Skip frameworks you’re not going to use

config.frameworks -= [ :action_web_service, :action_mailer ]

Add additional load paths for your own custom dirs

config.load_paths += %W( #{RAILS_ROOT}/extras )

Force all environments to use the same logger level

(by default production uses :info, the others :debug)

config.log_level = :debug

Use the database for sessions instead of the file system

(create the session table with ‘rake db:sessions:create’)

config.action_controller.session_store = :active_record_store

Use SQL instead of Active Record’s schema dumper when creating the

test database.

This is necessary if your schema can’t be completely dumped by the

schema dumper,

like if you have constraints or database-specific column types

config.active_record.schema_format = :sql

Activate observers that should always be running

config.active_record.observers = :cacher, :garbage_collector

Make Active Record use UTC-base instead of local time

config.active_record.default_timezone = :utc

See Rails::Configuration for more options

end

Add new inflection rules using the following format

(all these examples are active by default):

Inflector.inflections do |inflect|

inflect.plural /^(ox)$/i, ‘\1en’

inflect.singular /^(ox)en/i, ‘\1’

inflect.irregular ‘person’, ‘people’

inflect.uncountable %w( fish sheep )

end

Include your application configuration below

[cg@cg config]$


#4

Doesn’t look right to me :S

Mine says, with all the comments taken out:

RAILS_GEM_VERSION = ‘1.1.2’
require File.join(File.dirname(FILE), ‘boot’)
Rails::Initializer.run do |config|

end