Sybase ruby almost working

Hello Everyone, I am trying out sybase and ruby. I installed
freetds-0.64. I am able to connect to the sybase server in port 4101
using tsql. I am then downloaded sybct-ruby-0.2.9 and commented out
the freetds lines. I copied a few files to the ruby site path
cp sybct.o /usr/local/lib/site_ruby/1.8/i486-linux/
cp sybct.so /usr/local/lib/site_ruby/1.8/i486-linux/
cp sybct.rb /usr/local/lib/site_ruby/1.8/i486-linux/
cp sybsql.rb /usr/local/lib/site_ruby/1.8/i486-linux/

Then i ran irb1.8

require ‘sybsql’

and it worked but i am unable to connect using the samples

i get

ERROR: connect failed
./sybct.rb:27:in connect' ./sybct.rb:27:inopen’
./sybsql.rb:269:in initialize' ./sample/isql.rb:342:innew’
./sample/isql.rb:342

i also try using -S servername:4101 to change from the default 1433
but no cheese

any suggestions?

Its probably a case of not setting up the freetds.conf file. I’m pretty
sure you can’t directly provide a port, at least in v0.2.9, so you’ll
need to set up the conf file instead.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs