SwitchTower deployment


#1

I’ve been trying to configure SwitchTower to perform deployment of my
app to
a Dreamhost server. I can run rake remote_exec ACTION=setup just fine
but
rake deploy keeps giving me errors when its checking out the latest
revision
from the Subversion repository on the same Dreamhost server. It
displays
errors like this:

loading configuration c:/ruby/lib/ruby/gems/1.8/gems/switchtower-0.1
chtower/recipes/standard.rb
loading configuration ./config/deploy.rb
executing task deploy
transaction: start
executing task update_code
querying latest revision…
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Error resolving case of ‘svn+ssh:’
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.

Does anyone have any idea what’s wrong?


#2

On Jan 3, 2006, at 8:46 PM, Douglas T. wrote:

executing task deploy
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.
svn: Can’t create tunnel: The system cannot find the file specified.

Does anyone have any idea what’s wrong?

I don’t have much experience with either Ruby or Rails on Windows,
but it looks to me like the problem lies more with either subversion
or SSH. What happens if you try to access your repo directly from the
windows command-line: svn co svn+ssh://… ? Do you get the same error?

  • Jamis

#3

Hey Jamis,

I managed to solve the problem. It turns out I needed to specify a ssh
agent
for SVN. So I used cygwin’s ssh.exe and that solved the problem.