SwitchTower deployment has errors with different :db server


#1

When I define :db to be a different server than either :web or :app, and
run
“rake deploy”. Switchtower will abort with an
Net::SSH::AuthenticationFailed
error. The version of Switchtower I’m using is 1.0.0 and the deploy task
is
the default supplied with Switchtowe.

However, I dont have any problem when :db is changed to the same as :web
and
:app.


#2

On Feb 28, 2006, at 7:51 PM, Douglas T. wrote:

When I define :db to be a different server than either :web
or :app, and run “rake deploy”. Switchtower will abort with an
Net::SSH::AuthenticationFailed error. The version of Switchtower
I’m using is 1.0.0 and the deploy task is the default supplied with
Switchtowe.

However, I dont have any problem when :db is changed to the same
as :web and :app.

It sounds like the user/password combo you are using for the web and
app servers is not valid for the db server. Are you sure you can log
into the db server with the same credentials as those you use on the
web and app server?

  • Jamis

#3

the login credentials are different for the web server and the db
server. I
was under the assumption that Switchtower uses the login details from
database.yml for this?


#4

On Feb 28, 2006, at 10:45 PM, Douglas T. wrote:

the login credentials are different for the web server and the db
server. I was under the assumption that Switchtower uses the login
details from database.yml for this?

No, the database.yml does not (necessarily) describe the login
credentials for the server itself–it only gives you access to the
database–and so cannot be used as a reliable source for the login
info. SwitchTower treats all of your servers equally, and requires
that they all have the same login. There is not currently a way to
work around that restriction (that I’m aware of).

  • Jamis

#5

okay, thanks for the clarification, Jamis.