Svn: 'vendor/extensions' is not a working copy

Whenever I try to install an extension via subversion like this for
example:

cd /path/to/radiant

svn propset svn:externals “reorder -r881
http://svn.radiantcms.org/radiant/tags/rel_0-6-7/extensions/reorder/
vendor/extensions/.

I get this:

svn: ‘vendor/extensions’ is not a working copy

What is the problem?

I have also tried to manually download and upload the extension via ftp,
but then the rake command fails:

rake aborted!
uninitialized constant ApplicationController

Sorry for asking this many questions, couldn’t find a google-solution -
I would think that a lot of people just give up when trying this but I
really like Radiant, - maybe I could help a bit with the “getting up and
running quick” documentation, when I finally succeed?

It looks like your radiant_app directory is not in subversion, as far
as I remember from my limited experience with subversion you need to
have your Radiant application in svn (i.e. the directory containing
vendor/extensions) prior to adding externals – another possibility is
to just use svn export instead.

I believe however the core team is dropping the svn repo completely
soon, so an svn:external pointing there is probably not the best
longer term solution. You might want to look into git submodules, i.e.

git submodule add git://github.com/radiant/radiant-reorder-
extension.git vendor/extensions

You can also find tar/zip files for everything on github, i.e.

wget http://github.com/radiant/radiant-reorder-extension/tarball/master

Thank you

yes a tried with git on my local system which worked fine, but i don’t
think site5 (my hosting provider) supports git?

when i try:

git clone git://github.com/radiant/radiant-reorder-extension.git reorder

i get:

-bash: git: command not found

I recently deployed a Radiant project on a new RailsMachine VPS, and I
found the best way to avoid these issues is to create your local git
repository in the project, and use Capistrano’s option to copy a tarball
to the server. (set :deploy_via, :copy; set :copy_strategy, :export)
Then your server doesn’t need git at all. It’s probably past time that
we create some Radiant-specific recipes for Capistrano, don’t you think?

Sean

Ah, yeah that could be a problem. I bet they have at least one of wget
or curl installed which you can use to get the tar/zip files.

  1. cd /path/to/radiant_app/vendor/extensions

  2. wget
    http://github.com/radiant/radiant-reorder-extension/tarball/master

  3. tar xzvf radiant-radiant-reorder-
    extension-2295abc88438aef3c1836c24c5e8825e04ef16ef.tar.gz

  4. mv radiant-radiant-reorder-
    extension-2295abc88438aef3c1836c24c5e8825e04ef16ef reorder

  5. cd …/…

  6. rake radiant:extensions:reorder:migrate

Or something along those lines.

You have my vote for Radiant Cap recipes.

-Chris

I finally got the extension working (however some images to the buttons
are missing?)

I uploaded the tar.gz-file, unpacked it, renamed it to reorder

ran:

rake production db:migrate:extensions

it returned:

(in /home/chainrea/radapp)
== 1 AddPositionToPages: migrating

– add_column(:pages, :position, :integer)
-> 0.0335s
– Putting all pages in a default order…
-> 0.4285s
== 1 AddPositionToPages: migrated (0.4623s)

A warning though - it takes a minute or two before the extensions turns
up in the admin - at first I thought it didn’t work after all, but then
the it appeared after a short moment and a couple of manic log-outs/ins.
:slight_smile: Now it seems radiant is beginning to “radiate” for me… :slight_smile:

On 2008/07/13, at 15:23, Jan frederik Poulsen wrote:

I finally got the extension working (however some images to the
buttons
are missing?)

I think you probably forgot to run the update task,

cd /your/radiant_app
rake radiant:extensions:reorder:update

That will copy the necessary image and script assets to your public
folder.

Thank you

another thing one might struggle a bit with is “production” - as a
RoR-newbie I forgot that I have to target the environment I’m using or
else it will default to development.

rake production radiant:extensions:reorder:update

Oh and you can always, cd into your radiant app and run

rake -T

to see what tasks are available. extensions specific tasks will all be
grouped together in that list (in the radiant:extensions namespace),
so it’s pretty easy to figure out what tasks a given extension needs
you to run.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs