Sup 0.7 released


#1

I’m happy to announce the release of Sup 0.7.

The big win in this release is that Ferret index corruption issues
should now be fixed, thanks to an extensive programming of locking and
thread-safety-adding.

The other nice change is that text entry will now scroll to the right
upon overflow, thanks to some arcane Curses magic.

To get it: gem install sup, or visit http://sup.rubyforge.org.

What is it?

Sup is a console-based email client for people with a lot of email.
It supports tagging, very fast full-text search, automatic contact-
list management, and more. If you’re the type of person who treats
email as an extension of your long-term memory, Sup is for you.

Sup makes it easy to:

  • Handle massive amounts of email.

  • Mix email from different sources: mbox files (even across different
    machines), Maildir directories, IMAP folders, POP accounts, and
    GMail accounts.

  • Instantaneously search over your entire email collection. Search
    over body text, or use a query language to combine search
    predicates in any way.

  • Handle multiple accounts. Replying to email sent to a particular
    account will use the correct SMTP server, signature, and from
    address.

  • Add custom code to handle certain types of messages or to handle
    certain types of text within messages.

  • Organize email with user-defined labels, automatically track
    recent contacts, and much more!

The goal of Sup is to become the email client of choice for nerds
everywhere.

Select changes in this release:

  • Ferret index corruption issues fixed (hopefully!)
  • Text entry now scrolls to the right on overflow, i.e. is actually
    usable
  • Ctrl-C now asks user if Sup should die ungracefully
  • Add a limit: search operator to limit the number of results
  • Added a --query option to sup-tweak-labels
  • Added a new hook: shutdown
  • Automatically add self as recipient on crypted sent messages
  • Read in X-Foo headers
  • Added global keybinding ‘U’ shows only unread messages
  • As always, many bugfixes and tweaks

#2

Reformatted excerpts from Jesús Gabriel y Galán’s message of 2009-03-25:

Then when trying to run sup-config I had to manually install the
following gems in order to make it work:

echoe
archive-tar-minitar
nokogiri
hoe
rcov

None of these are requirements from Sup. None of those strings exist
anywhere in the Sup code.

I think the problem is that these are listed as development
dependencies that older versions of Rubygems interpret as runtime
dependencies, but not as installation prerequisites. But I ain’t a gems
expert. If you’re using rubygems < 1.3.1, you might retry with a later
version. (Or not, since you’ve fixed the problem the easy way.)


#3

On Wed, Mar 25, 2009 at 3:50 PM, William M.
removed_email_address@domain.invalid wrote:

I’m happy to announce the release of Sup 0.7.

To get it: gem install sup, or visit http://sup.rubyforge.org.

Hi,

I am trying to get started with sup, and I got some problems regarding
gem dependencies.
I am in Ubuntu 8.10:

jesus@jesus-laptop:~/$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i486-linux]
jesus@jesus-laptop:~/$ gem1.8 -v
1.2.0

I did:

gem install sup

and it installed this:

jesus@jesus-laptop:~/$ sudo gem1.8 install sup
Building native extensions. This could take a while…
Successfully installed lockfile-1.4.3
Successfully installed mime-types-1.16
Successfully installed locale-2.0.0
Successfully installed gettext-2.0.0
Successfully installed fastthread-1.0.5
Successfully installed sup-0.7
6 gems installed

Then when trying to run sup-config I had to manually install the
following gems in order to make it work:

echoe
archive-tar-minitar
nokogiri
hoe
rcov

After that, it worked. I’m going to mess around a little bit with this
to see if I can get used to it, but idea looks very promising. I use
gmail for my personal email and agree with the ideas you have taken
from them. I would like to use sup for my work email, but I would need
it to support pop, so I’ll have to wait for that. Anyway, thanks for
sup, it looks great !

Hope this helps,

Jesus.


#4

William M. wrote:

I’m happy to announce the release of Sup 0.7.

The big win in this release is that Ferret index corruption issues
should now be fixed, thanks to an extensive programming of locking and
thread-safety-adding.

Is it 1.9 compatible? I do not see any mention on that. I tried to
install ferret and it fails compilation (this is with clang/ccc but I do
not think this is the issue there).

ccc -I. -I/usr/local/include/ruby-1.9//amd64-freebsd7
-I/usr/local/include/ruby-1.9//ruby/backward
-I/usr/local/include/ruby-1.9/ -I. -fPIC -O -pipe -O2 -g -Wall
-Wno-parentheses -fPIC -D_FILE_OFFSET_BITS=64 -oglobal.o -c global.c
global.c:307:32: warning: format string is not a string literal
(potentially insecure)
sprintf(q, s);
^
global.c:372:24: error: incompatible type passing ‘int’, expected
‘struct timeval’
rb_thread_wait_for(rb_time_interval(rb_float_new((double)micro_seconds/1000000.0)));
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2 diagnostics generated.
*** Error code 1


#5

On Wed, Mar 25, 2009 at 5:39 PM, William M.
removed_email_address@domain.invalid wrote:

None of these are requirements from Sup. None of those strings exist
anywhere in the Sup code.

I think the problem is that these are listed as development
dependencies that older versions of Rubygems interpret as runtime
dependencies, but not as installation prerequisites. But I ain’t a gems
expert. If you’re using rubygems < 1.3.1, you might retry with a later
version. (Or not, since you’ve fixed the problem the easy way.)

I’m no rubygems expert either, so I though I’d mention the problem I
had.
If this is an already well known issue, sorry for the noise.

Regards,

Jesus.


#6

Reformatted excerpts from Ollivier R.'s message of 2009-03-27:

Is it 1.9 compatible? I do not see any mention on that.

Very far from it. If nothing else, it has 10 gem dependencies, and I’d
guess at least 8 of those are not 1.9-ready.