Suddenly a Blank Page


#1

This is apache/fcgi/rails/firefox.

When using a rails app we have been experiencing sudden blank pages in
the browser.

We show an model “new object” page and start changing stuff and all of a
sudden the page will be erased to blank!

Any idea what could cause something like this?


#2

I experienced the same when I was trying to call a partial that did not
exist.

 Erik.

Richard W. schreef:


#3

Am 23.02.2006 um 16:37 schrieb Richard W.:

This is apache/fcgi/rails/firefox.

When using a rails app we have been experiencing sudden blank pages in
the browser.

We show an model “new object” page and start changing stuff and all
of a
sudden the page will be erased to blank!

Any idea what could cause something like this?

If you’re running WEBrick, try to remove the ruby session files in /tmp.

*m


#4

Removing the session files worked for me…I had to
do it after switching versions and port for mysql.
Presumably old connection info was in sesion files.

sudden the page will be erased to blank!

Any idea what could cause something like this?

If you’re running WEBrick, try to remove the ruby session files in /tmp.


#5

Manuel H. wrote:

Am 23.02.2006 um 16:37 schrieb Richard W.:

This is apache/fcgi/rails/firefox.

When using a rails app we have been experiencing sudden blank pages in
the browser.

We show an model “new object” page and start changing stuff and all
of a
sudden the page will be erased to blank!

Any idea what could cause something like this?

If you’re running WEBrick, try to remove the ruby session files in /tmp.

*m

I saw this when switching to DB driven sessions in the environment.rb.
It worked for a while and then all of a sudden, everything was blank. I
turned it off for the moment (back to /tmp) and it is all good. Sorry,
no solution.

Fredrik


#6

Richard W. wrote:

Today, I had a problem with sessions that caused that problem. The
session table you can create with rake will use a TEXT column for data,
this tops out at 64KB. I changed this to LONGTEXT and the problem went
away.


Jack C.
removed_email_address@domain.invalid


#7

Richard W. wrote:

This is apache/fcgi/rails/firefox.

When using a rails app we have been experiencing sudden blank pages in
the browser.

We show an model “new object” page and start changing stuff and all of a
sudden the page will be erased to blank!

Any idea what could cause something like this?

Do the pages remain blank, or do they work after reloading? I have this
problem on ruby-forum.com (using memcached sessions).


#8

On Tuesday, February 28, 2006, at 11:18 AM, Andreas S. wrote:

Do the pages remain blank, or do they work after reloading? I have this
problem on ruby-forum.com (using memcached sessions).


Posted via http://www.ruby-forum.com/.


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails

Once they are reloaded they work fine.

More info: This usually happens while data is being entered into one
particular page (the page that is used most often in the app). You will
be entering data normally then BAM a blank page. Weird


#9

On 2/23/06, Fredrik removed_email_address@domain.invalid wrote:

I saw this when switching to DB driven sessions in the environment.rb.
It worked for a while and then all of a sudden, everything was blank. I
turned it off for the moment (back to /tmp) and it is all good. Sorry,
no solution.

We’ve seen behaviour in development mode where an application using
DB-backed sessions will suddenly fail because it tries to revert to
pstore sessions - production mode fixes this though. This behaviour
was also in Rails of yore, so it might’ve been fixed, but the
description matches what you’ve got, Fredrik.

  • james

#10

On Thursday, February 23, 2006, at 3:37 PM, Richard W. wrote:


Posted with http://DevLists.com. Sign up and save your time!


Rails mailing list
removed_email_address@domain.invalid
http://lists.rubyonrails.org/mailman/listinfo/rails

When this happens I can move to a different page and then back and
everything seems to be ok then.