Strange problem with flash videos

Hi everyone i am making a RoR application that contains flv videos
like youtube. It has worked ok when i embedded the flv videos in
moodle but now i have a very strange problem
First of all I use the FLASH PLAYER 3.3 which is a quite common
player.
I have uploaded the videos in the public folder and i have stored
their path in the db
When i enter (so far you can access the app (from the Internet))
http://etsl.imm.demokritos.gr/word
it works and i can see the videos
when it changes to
http://etsl.imm.demokritos.gr/word/
i can see nothing and no Javascript complaints !!! Plus the output
HTML is the same as before. So bizarre !
Also i made a contoller to view the videos by category, it works it
produces the right HTML but the videos do not load neither the
player !

Any ideas, suggestions ?
I do not think anyone has encountered something so strange

Just to add something
I just checked with WebRick
as i said when i add a slash at end the videos do not appear
and webrick gives me that:

Processing Base#index (for 91.140.18.241 at 2007-05-11 23:31:17) [GET]
Session ID: bc651fe3d0fac25477d5af2c51212ea4
Parameters: {}

ActionController::RoutingError (Recognition failed for “/word/category/
flash/flvplayer.swf”):
/vendor/rails/actionpack/lib/action_controller/routing.rb:522:in
recognition_failed' /vendor/rails/actionpack/lib/action_controller/routing.rb:512:inrecognize!’
/vendor/rails/railties/lib/dispatcher.rb:38:in dispatch' /vendor/rails/railties/lib/fcgi_handler.rb:150:inprocess_request’
/vendor/rails/railties/lib/fcgi_handler.rb:54:in process!' /usr/lib/ruby/1.8/fcgi.rb:612:ineach_cgi’
/usr/lib/ruby/1.8/fcgi.rb:117:in session' /usr/lib/ruby/1.8/fcgi.rb:104:ineach_request’
/usr/lib/ruby/1.8/fcgi.rb:36:in each' /usr/lib/ruby/1.8/fcgi.rb:609:ineach_cgi’
/vendor/rails/railties/lib/fcgi_handler.rb:53:in process!' /vendor/rails/railties/lib/fcgi_handler.rb:23:inprocess!’
/var/www/etsl/public/dispatch.fcgi:26

And that thing is the script for the video:

The strange think is that even when i give directly the link:
http://143.233.16.42:3000/word/category/2
It still produces the same error !

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs