Strange Gtk Error/Warining

Hi,

I saw something regarding few other exceptions like that, but it wasn’t
exactly like this:

when I’m making in the irb, "require ‘gtk2’ " I got the following
errors:

/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion
g_type_from_name (name) == 0' failed /usr/lib/ruby/1.8/glib2.rb: line 55 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED
(boxed_type)’ failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
G_IS_PARAM_SPEC (pspec)' failed /usr/lib/ruby/1.8/glib2.rb: line 55 GLib-GObject-CRITICAL **:g_param_spec_boxed: assertionG_TYPE_IS_BOXED
(boxed_type)’ failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion
`G_IS_PARAM_SPEC (pspec)’ failed

This happening also when the script, that is using libglade2, is
running.
Nothing bad seems to be happening, but I don’t understand why is that

This is happening in Ubuntu Edgy.

What is bothering me, is that I see there, CRITICAL, this shouldn’t be
right.

Any idea about that ?
Is there a solution how to fix that ?

Thanks in advance.


Best Regards,

Alin

Hi,

In [email protected]
“[ruby-gnome2-devel-en] Strange Gtk Error/Warining” on Sat, 11 Nov
2006 16:44:54 +0200,
“Alin P.” [email protected] wrote:

Any idea about that ?
Is there a solution how to fix that ?

Use CVS version of Ruby-GNOME2.

Thanks,

kou


Using Tomcat but need to do more? Need to support web services,
security?
Get stuff done quickly with pre-integrated technology to make your job
easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642

Thank you Kou.

On 11/11/06, Kouhei S. [email protected] wrote:

Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642


ruby-gnome2-devel-en mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/ruby-gnome2-devel-en


Best Regards,

Alin

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs