Strange crc error when install rails with gem


#1

has anyone seen this before:

~$ gem install rails
Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency rake? [Yn]
Install required dependency activesupport? [Yn]
ERROR: While executing gem … (Zlib::GzipFile::CRCError)
invalid compressed data – crc error

vader:/opt/bin # arch
x86_64

$ uname -a
Linux vader 2.6.12.4-sis190-050808a #1 SMP Mon Aug 8 01:08:43 CEST 2005
x86_64 x86_64 x86_64 GNU/Linux

I am running Suse 9.3

Regards
Peter


#2

On Nov 11, 2005, at 4:32 AM, Pete wrote:

invalid compressed data -- crc error

Hey Pete-

I think you are missing the zlib-devel package. I am not sure what

this package is called on Suse as I use debian but that is the same
error you get when you don’t have the zlib dev headers.

HTH-

-Ezra Z.
WebMaster
Yakima Herald-Republic Newspaper
removed_email_address@domain.invalid
509-577-7732