Strange behavior of Kernel::system

Hi

I am running Ruby on Ubunutu 7.10. I have a shell script building my
software (doFullBuild) with one Parameter (the SVN revision number).

When I call this script directly from Linux terminal (e.g. ./
doFullBuild -r 134 >logFile_r134.log 2>logFile_r134.error.log &) it
checks out the SW sources and builds the software - and everything is
fine.

I now enhanced my build system by using Ruby (and Fox-GUI library).
There in the Ruby script I have:
system(’./doFullBuild -r 134 >logFile_r134.log
2>logFile_r134.error.log &’)
This should do exactly the same as when I run it directly from Linux
terminal - shouldn’t it? BUT - it does not and I need help about how I
can further analyze this problem.
Some parts are not built and I have no idea what is the difference
between calling doFullBuild directly in Linux terminal or by calling
it (via system) from my Ruby script.

Any hints for me?

BR Phil

I have found a problem in the bash script (empty command, i.e. “:” and
next line being interpreted as options for this command) being called
by my Ruby script. Still I do not understand why there is a difference
between calling the bash script from a Linux terminal window and
calling it from within Ruby.

But what I had to solve is solved.

BR Phil

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs