Strage mongrel cluster

Hi,will appreciate any advice from ruby guru :

I found strange behavior on mongrel cluster. Below are my installation
details :
#ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux]

#rails -v
Rails 2.3.5

I use mongrel cluster 1.0.5 on Debian lenny (5.0). Also got the same
problem in ubuntu 8 LTS, with similar config.

when running just mongrel , it works properly. But when I tried to use
mongrel cluster, when I run :

#sudo mongrel_rails cluster::configure -e production -p 8000 -N 3 -c
/home/public_html/redmine -a 0.0.0.1 --user www-data --group www-data

#sudo mongrel_rails cluster::start
starting port 8000
starting port 8001
starting port 8002

No error messages.
Then I checked with netstat -tap, there were no mongrel listening on
800x.
and check with px aux | grep mongrel, also nothing.

seems that there were no mongrel process running. Any help?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs