Stop receiving in tunnel.py


#1

Hello everyone,

I am doing some modifications on the tunnel.py example. At some point
of the execution, I would like to stop the receive path and not to
perform the rx_callback for a very short period, less than one second
probably. I would like to know if there is a way I can just inhibit
the USRP to receive or to process the samples without
stopping/restarting the flowgraph. I am using the Flex2400
daughterbord. Alternative methods that can do the service are also
welcome!

Thanks!

Natalia Olano


#2

On Tue, Mar 17, 2009 at 09:06:36AM +0100, Natalia Olano wrote:

Thanks!
Natalia Olano

Can you say more about what you’re trying to do? Why do you want to
ignore samples during this period?

Eric


#3

Hi Eric,

Yes, I haven’t gone into much detail… Sorry, here it is:

The project is a multiuser testbed with several USRP1s. The host
computers are connected with an Ethernet switch among themselves and
also to a central node for logging purposes. Every 10s or so they
should exchange information on the link quality over the wired
network. In an ideal case, the exchange of this information should
cause just a very short interruption on the air link.

Now the problem is that the timer to receive on the socket and process
the information on the wired network is ignored by the receivers when
there are still some packets being transmitted over the air. Since
these packets are transmitted at a fairly high rate, the receivers are
performing the receive callback constantly and delay their functions
on the wired network. I would like to be able to disable this callback
in some way for a very short time to save this processing time and
perform promptly the link state update over the wired interface. I
have already tried stopping the flowgraph, which was too slow and
having a 10-100ms sleep in the receive callback, which helped but did
not work in all the cases.

I would be very grateful if you could suggest a solution.
Thanks!

Natalia Olano