Status ruby 1.9 rails or 1.8 w/oniguruma

what is the official status on v1.9 with rails or how to get vy.n to
work w/oniguruma?

plz provide a good spot to track dependencies as there doesnt seem to
be a definitive answer

whoops that was typed on my phone, vy.n = v1.8 …

On Apr 25, 2008, at 19:12 PM, jOhn wrote:

what is the official status on v1.9 with rails or how to get v[1.8] to
work w/oniguruma?

For 1.8:

a) install the oniguruma C library.
b) gem install oniguruma
c) require ‘oniguruma’

Eric H. wrote:

c) require ‘oniguruma’
Also worth mentioning JRuby 1.1.x is compatible with 1.8 and ships with
an oniguruma port as the default regexp.

  • Charlie

ok but i asked b/c onig fails to compile on ubuntu via gem install, so
it is broken but ill follow some workarounds.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs