Status of mod_ruby

With ruby 1.8.7 (2008-06-20 patchlevel 22) I was unable to compile
mod_ruby

Looking at the last release ~2 years ago of mod_ruby I wonder if it was
abandoned?

Marc H. wrote:

With ruby 1.8.7 (2008-06-20 patchlevel 22) I was unable to compile
mod_ruby

Looking at the last release ~2 years ago of mod_ruby I wonder if it was
abandoned?

It’s in the Ubuntu repositories, so the package maintainers should at
least keep it working with the verion of Ruby in Ubuntu.

I also wish that mod_ruby would see some development. Mod_ruby + erubis
is great for small little projects where a framework is way overkill
(such as times I’ve wanted to add just a few lines of script inside a
single page). For now, the only alternative is to use php in such a
situation, which is probably a better choice right now if you care to
learn another language. In my case though, my primary job function is a
system administrator, and I just can’t seem to grasp php where-as ruby
took practically no effort for me to learn. So I’m hoping either
mod_ruby gets some momentum or Passenger adds the ability to render
standalone rhtml files via erubis.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs