Status of GNU Radio on Mac OS X

If you use MacPorts under Mac OS X 10.5, .6, or .7, “sudo port install
gnuradio” should work as of this morning for installing all of the
background dependencies (and, version GR 3.3.0 from the tarball if
that’s good enough). I had to fix SDCC 2.9 to work under 10.7, as well
as tweak GNU Radio 3.3.0 tarball’s configure script to correctly set the
MD_CPU types under 10.7 (just like when 10.6 came out). It looks like
the MD_CPU issue has been fixed since the 3.3.0 release, as the current
GIT master seems to build cleanly and make check (as correctly as
possible) on 10.7 (64 bit) with no changes (and with Volk disabled).
The UDP QA code doesn’t work any better on 10.7 than on 10.6. I think
the primary OSX issue right now is setting the audio input device sample
rate using using it as an audio source. There are a few of us looking
into this issue as time allows; hopefully nobody is truly dependent on
this feature when using OSX. - MLD

On Fri, Sep 23, 2011 at 2:57 PM, Michael D. [email protected]
wrote:

setting the audio input device sample rate using using it as an audio
source. There are a few of us looking into this issue as time allows;
hopefully nobody is truly dependent on this feature when using OSX. - MLD

Thanks Michael!

Tom

Awesome
On Sep 23, 2011 5:31 PM, “Tom R.” [email protected] wrote:

On Fri, Sep 23, 2011 at 2:57 PM, Michael D. [email protected] wrote:

If you use MacPorts under Mac OS X 10.5, .6, or .7, “sudo port install
gnuradio” should work as of this morning for installing all of the
background dependencies (and, version GR 3.3.0 from the tarball if that’s
good enough). I had to fix SDCC 2.9 to work under 10.7, as well as tweak
GNU Radio 3.3.0 tarball’s configure script to correctly set the MD_CPU
types

under 10.7 (just like when 10.6 came out). It looks like the MD_CPU issue
has been fixed since the 3.3.0 release, as the current GIT master seems
to

build cleanly and make check (as correctly as possible) on 10.7 (64 bit)
with no changes (and with Volk disabled). The UDP QA code doesn’t work
any

I tried this out, and it almost worked perfectly.

Two things needed fiddling:

Gnuradio and most of the python dependencies were installed for
python2.6. My default was 2.5 so I had to switch to using the 2.6
version installed by macports.

Most of the python dependencies were installed to:
/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/

The gnuradio python stuff was installed to:
/opt/local/lib/python2.6/site-packages
which was not on the python-path and had to be added manually.

It wasn’t that python2.5 didn’t work, rather that macports didn’t
attempt to install gnuradio for that version. Instead it installed
python2.6 and setup gnuradio for that. I’ve never messed about with
macports scripts so I don’t know why that might happen.

On Sep 25, 2011, at 8:39 PM, Ben R. wrote:

It wasn’t that python2.5 didn’t work, rather that macports didn’t
attempt to install gnuradio for that version. Instead it installed
python2.6 and setup gnuradio for that. I’ve never messed about with
macports scripts so I don’t know why that might happen.

If you do “port info gnuradio”, you’ll see:

gnuradio @3.3.0 (science)
Variants: docs, python25, [+]python26, python27

which means that if you do “sudo port install gnuradio” – install with
default variants – then it will do so for use with Python 2.6. If you
want to use gnuradio with Python 2.5, then you’ll want to do “sudo port
install gnuradio +python25”.

Hope that helps & makes sense. - MLD

On Sun, Sep 25, 2011 at 5:54 PM, Michael D. [email protected]
wrote:

Variants: docs, python25, [+]python26, python27

which means that if you do “sudo port install gnuradio” – install with default
variants – then it will do so for use with Python 2.6. If you want to use
gnuradio with Python 2.5, then you’ll want to do “sudo port install gnuradio
+python25”.

Hope that helps & makes sense. - MLD

Makes sense. I didn’t know about that.

On Sun, Sep 25, 2011 at 10:13 PM, Ben R. [email protected] wrote:

gnuradio @3.3.0 (science)

Makes sense. I didn’t know about that.

Great. Thanks again Michael!

Tom

On Sun, Sep 25, 2011 at 11:15 AM, Ben R. [email protected] wrote:

I tried this out, and it almost worked perfectly.

Two things needed fiddling:

Gnuradio and most of the python dependencies were installed for
python2.6. My default was 2.5 so I had to switch to using the 2.6
version installed by macports.

Thanks for the report. Did you see where Python 2.5 failed to work?
We’re
supposed to be compatible with it, so if it’s stuff we can fix to make
it
compatible again, we will.

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs