Starting Server gives an error


#1

Hi,
I had created a new environment and tried to start the webrick server
for that environment but it is giving an error:-

E:/demo/vendor/rails/railties/lib/commands/servers/
webrick.rb:11: warning: already initialized constant OPTIONS
E:/demo/vendor/rails/activesupport/lib/active_suppo
rt/dependencies.rb:249:in load_missing_constant': Expected E:/Demo /vendor/plugins/eons_plugins/acts_as_paranoid/lib/caboose/acts/p aranoid.rb to define Caboose::Acts::Paranoid (LoadError) from E:/Demo/vendor/rails/activesupport/lib /active_support/dependencies.rb:452:inconst_missing’
from E:Demo/vendor/plugins/eons_plugins/ac
ts_as_paranoid/init.rb:1:in load_plugin' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:407: inload_plugin’
from E:/Demo/vendor/rails/activesupport/lib
/active_support/core_ext/kernel/reporting.rb:11:in silence_warnings' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:407: inload_plugin’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:189:
in load_plugins' from ./script/../config/../vendor/rails/railties/lib/initializer.rb:189: ineach’
from
./script/…/config/…/vendor/rails/railties/lib/initializer.rb:189:
in load_plugins' ... 15 levels... from E:/Demovendor/rails/railties/lib/comm ands/server.rb:39 from D:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:inge
m_original_require’
from
D:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:32:in `re
quire’
from script/server:3
I installed the acts_as_paranoid (0.3.1).
But still it is giving an error.
My gems are :-
*** LOCAL GEMS ***

actionmailer (2.1.1, 1.3.3)
Service layer for easy email delivery and testing.

actionpack (2.1.1, 1.13.6, 1.13.3)
Web-flow and rendering framework putting the VC in MVC.

actionwebservice (1.2.6, 1.2.3)
Web service support for Action Pack.

activerecord (2.1.1, 1.15.6, 1.15.3)
Implements the ActiveRecord pattern for ORM.

activesupport (2.1.1, 1.4.4, 1.4.2)
Support and utility classes used by the Rails framework.

acts_as_paranoid (0.3.1)
acts_as_paranoid keeps models from actually being deleted by setting
a deleted_at field.

cgi_multipart_eof_fix (2.5.0)
Fix an exploitable bug in CGI multipart parsing.

daemons (1.0.10)
A toolkit to create and control daemons in different ways

dsl_accessor (0.1.0)
This gem gives hybrid accessor class methods to classes by DSL like
definition.

fastercsv (1.4.0)
FasterCSV is CSV, but faster, smaller, and cleaner.

fxri (0.3.7, 0.3.6)
Graphical interface to the RI documentation, with search engine.

fxruby (1.6.12)
FXRuby is the Ruby binding to the FOX GUI toolkit.

gem_plugin (0.2.3)
A plugin system based on rubygems that uses dependencies only

hoe (1.8.0, 1.1.7)
Hoe is a simple rake/rubygems helper for project Rakefiles

hpricot (0.6)
a swift, liberal HTML parser with a fantastic library

json (1.1.1)
A JSON implementation as a Ruby extension

log4r (1.0.5)
Log4r is a comprehensive and flexible logging library for Ruby.

memcache-client (1.5.0)
A Ruby memcached client

mysql (2.7.3)
A win32-native build of the MySQL API module for Ruby.

needle (1.3.0)
Needle is a Dependency Injection/Inversion of Control container for
Ruby. It supports both type-2 (setter) and type-3 (constructor)
injection. It takes advantage of the dynamic nature of Ruby to
provide a rich and flexible approach to injecting dependencies.

net-ssh (1.1.2)
Net::SSH is a pure-Ruby implementation of the SSH2 client protocol.

rails (1.2.3)
Web-application framework with template engine, control-flow layer,
and ORM.

rake (0.8.3, 0.7.3)
Ruby based make-like utility.

recaptcha (0.1.49)
description of gem

rmagick (1.14.1)
RMagick is an interface between the Ruby programming language and
the ImageMagick and GraphicsMagick image processing libraries.

ruby-debug-base (0.10.0)
Fast Ruby debugger - core component

ruby-debug-ide (0.1.10)
IDE interface for ruby-debug.

rubyforge (1.0.0)
A script which automates a limited set of rubyforge operations

sources (0.0.1)
This package provides download sources for remote gem installation

sqlite3-ruby (1.2.1)
SQLite3/Ruby is a module to allow Ruby scripts to interface with a
SQLite database.

sys-proctable (0.7.6)
An interface for providing process table information

win32-api (1.0.0)
A superior replacement for Win32API

win32-clipboard (0.4.3)
A package for interacting with the Windows clipboard

win32-dir (0.3.2)
Extra constants and methods for the Dir class on Windows.

win32-eventlog (0.4.6)
Interface for the MS Windows Event Log.

win32-file (0.5.4)
Extra or redefined methods for the File class on Windows.

win32-file-stat (1.2.5)
A File::Stat class tailored to MS Windows

win32-process (0.5.3)
Adds fork, wait, wait2, waitpid, waitpid2 and a special kill method

win32-sapi (0.1.4)
An interface to the MS SAPI (Sound API) library.

win32-sound (0.4.1)
A library for playing with sound on MS Windows.

windows-api (0.2.0)
An easier way to create methods using Win32API

windows-pr (0.7.1)
Windows functions and constants bundled via Win32::API

ZenTest (3.10.0)
ZenTest provides 4 different tools and 1 library: zentest,
unit_diff, autotest, multiruby, and Test::Rails

Can anyone tell what is remaining to install?

Thanks,
Tushar


#2

Tushar G. wrote:

Hi,
I had created a new environment and tried to start the webrick server
for that environment but it is giving an error:-

E:/demo/vendor/rails/railties/lib/commands/servers/
webrick.rb:11: warning: already initialized constant OPTIONS
E:/demo/vendor/rails/activesupport/lib/active_suppo
rt/dependencies.rb:249:in `load_missing_constant’: Expected E:/Demo
/vendor/plugins/eons_plugins/acts_as_paranoid/lib/caboose/acts/p
aranoid.rb to define Caboose::Acts::Paranoid (LoadError)
from E:/Demo/vendor/rails/activesupport/lib

what is the rails version in your config/environment.rb file?