Starting mongrel rails server error

I have a new rails installation on a Mac and am running into problems
when trying to start my mongrel server (mongrel_rails start). The
application I’m working on was created from an older version of rails
(windows); could that be the problem? If so, how can I resolve this?
Any help is appreciated…

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment…
/usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/
active_record/connection_adapters/abstract/connection_specification.rb:
14: undefined method cattr_accessor' for ActiveRecord::Base:Class (NoMethodError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in require' from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.15.3/lib/ active_record/connection_adapters/abstract_adapter.rb:10 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in require' from /Users/marksmith/src/apps/sasg3/trunk/config/db2odbc_adapter.rb: 82 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 27:ingem_original_require’
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
27:in require' ... 12 levels... from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.4/bin/../lib/ mongrel/command.rb:212:inrun’
from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.4/bin/
mongrel_rails:281
from /usr/local/bin/mongrel_rails:19:in `load’
from /usr/local/bin/mongrel_rails:19

Are you sure you have the activesupport gem installed? Try:

sudo gem install activesupport

and then see if your server will boot up.

ESPNDev

My initial thoughts were along those lines; maybe my installation was
corrupt or I installed something in the wrong order so I uninstalled
all gems and then uninstalled rails. From there I reinstalled rails
from scratch.

This is only happening with this existing project. If I create a new
project mongrels starts like a champ.

*** LOCAL GEMS ***

actionmailer (2.0.2, 1.3.3)
actionpack (2.0.2, 1.13.3)
actionwebservice (1.2.3)
activerecord (2.0.2, 1.15.3)
activeresource (2.0.2)
activesupport (2.0.2, 1.4.2)
capistrano (2.3.0)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
fastthread (1.0.1)
gem_plugin (0.2.3)
highline (1.4.0)
hoe (1.5.1)
mongrel (1.1.4)
mysql (2.7)
net-scp (1.0.0)
net-sftp (2.0.0)
net-ssh (2.0.1)
net-ssh-gateway (1.0.0)
ParseTree (2.1.1)
rails (2.0.2, 1.2.3)
rake (0.8.1)
RedCloth (3.0.4)
rspec (1.1.3)
ruby2ruby (1.1.8)
rubyforge (0.4.5)
RubyInline (3.6.7)
sake (1.0.14)
termios (0.9.4)

On May 15, 6:13 pm, “[email protected]” <ESPN3.DL-

On 15 May 2008, at 21:36, smitty26 wrote:

I have a new rails installation on a Mac and am running into problems
when trying to start my mongrel server (mongrel_rails start). The
application I’m working on was created from an older version of rails
(windows); could that be the problem? If so, how can I resolve this?
Any help is appreciated…

Does environment.rb nominate a particular version of rails to use (and
is that version installed?)

Fred

It does, 1.2.3 and I installed it via the gem command (sudo gem
install rails -v 1.2.3). Still no luck.

On May 16, 9:44 am, Frederick C. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs