Ssleay32.dll, postgresql, extension problem

Hi all,

The PostgreSQL 8.3 release ships with its own ssleay32.dll. However,
when building with VC++ 6 using the one-click installer, I need to use
the ssleay32.dll that Curt ships under c:/ruby/bin.

I’ve been toying with $LDFLAGS and $LIBPATH but I can’t make it work. I
always get a “The ordinal 284 could not be located in the dynamic link
library SSLEAY32.DLL”.

What mkmf incantation must I perform to make it work?

Regards,

Dan

I’ve been fighting this problem on Vista with EventMachine, although
not directly with postgresql.

I have yet to find a solution, although I suspect it will be necessary
in some cases to build everything with the same stack.

Hi,

At Sun, 10 Feb 2008 07:11:55 +0900,
Daniel B. wrote in [ruby-talk:290550]:

The PostgreSQL 8.3 release ships with its own ssleay32.dll. However,
when building with VC++ 6 using the one-click installer, I need to use
the ssleay32.dll that Curt ships under c:/ruby/bin.

I’ve been toying with $LDFLAGS and $LIBPATH but I can’t make it work. I
always get a “The ordinal 284 could not be located in the dynamic link
library SSLEAY32.DLL”.

Maybe, INCLUDE and LIB environment variables are set for
PostgreSQL?

If rubygems is already loaded then aren’t the symbols for openssl
already present in memory before any postgresql extension is loaded?

On Feb 9, 8:53 pm, Nobuyoshi N. [email protected] wrote:

always get a “The ordinal 284 could not be located in the dynamic link
library SSLEAY32.DLL”.

Maybe, INCLUDE and LIB environment variables are set for
PostgreSQL?

Explicitly setting ENV in the extconf.rb script didn’t seem to help.

Any recommendations?

Thanks,

Dan

Nobuyoshi N. wrote:

library SSLEAY32.DLL".

Maybe, INCLUDE and LIB environment variables are set for
PostgreSQL?

I tried setting both LIB and LIBDIR to C:\ruby\bin, both in the shell
itself and via ENV, but it didn’t work.

Have you been able to build and load ruby-pg against PostgreSQL 8.3 with
the one click installer? If so, how did you do it?

Regards,

Dan

Sethupathi Asokan wrote:

Daniel B. wrote:

Nobuyoshi N. wrote:

library SSLEAY32.DLL".

Maybe, INCLUDE and LIB environment variables are set for
PostgreSQL?

I tried setting both LIB and LIBDIR to C:\ruby\bin, both in the shell
itself and via ENV, but it didn’t work.

Have you been able to build and load ruby-pg against PostgreSQL 8.3 with
the one click installer? If so, how did you do it?

Regards,

Dan

I have done a work-around by renaming the libeay32.dll and ssleay32.dll
in {RUBY_PATH}/bin directory and copy these to dll files from
{POSTGRES_PATH}/bin directory and paste it under {RUBY_PATH}/bin.

It worked for me.

My work-around worked in just the opposite way. Having boy files
libeay32.dll and ssleay32.dll in {POSTGRES_PATH}/bin directory and
nothing in {RUBY_PATH}/bin directory, finally did the trick, but I
noticed they had to have the same date.

Daniel B. wrote:

Nobuyoshi N. wrote:

library SSLEAY32.DLL".

Maybe, INCLUDE and LIB environment variables are set for
PostgreSQL?

I tried setting both LIB and LIBDIR to C:\ruby\bin, both in the shell
itself and via ENV, but it didn’t work.

Have you been able to build and load ruby-pg against PostgreSQL 8.3 with
the one click installer? If so, how did you do it?

Regards,

Dan

I have done a work-around by renaming the libeay32.dll and ssleay32.dll
in {RUBY_PATH}/bin directory and copy these to dll files from
{POSTGRES_PATH}/bin directory and paste it under {RUBY_PATH}/bin.

It worked for me.

On Jun 8, 12:58 pm, Krystyna W. [email protected]
wrote:

It worked for me.

My work-around worked in just the opposite way. Having boy files
libeay32.dll and ssleay32.dll in {POSTGRES_PATH}/bin directory and
nothing in {RUBY_PATH}/bin directory, finally did the trick, but I
noticed they had to have the same date.

Please try RubyInstaller:

http://rubyinstaller.org/

It includes OpenSSL in “compatibility mode” so it doesn’t conflict
with PostgreSQL.