SSL plugin


#1

HAppy new year.

I was trying to turn on SSL. On trying to install the plugin for ssl I
get an error message that the plugin was not found. Any one with an
alternative can help me out.

This is what I used to instalthe plugin on my version 1.8.6 ruing on a
windows platform.

ruby script/plugin install ssl_requirement

Thank you

Love is the greatest


#2

Hi,

Could you share the error message what you receive while executing that
command

-NAYAK


#3

The error mesage I get is
Plugin not found: [“ssl_requirement”]

On 1/6/09, NAYAK removed_email_address@domain.invalid wrote:

ruby script/plugin install ssl_requirement

Thank you

Love is the greatest


Love is the greatest


#4

ruby script/plugin install ssl_requirement

Thank you

In you application controller file add:

include SslRequirement

Best regards,

Video training screencasts at http://www.digiprof.fr


#5

Fritz A. wrote:

At the terminal I see:

==
$ ruby script/plugin install ssl_requirement
Plugin not found: [“ssl_requirement”]

… and the answer is that the one source repository built into
script/plugin was down, or somehow dropped ssl_requirement. The solution
is to look at other repositories:

==
script/plugin discover

… and accept some additional repositories for plugins. script/plugin
can then find ssl_requirement. Problem solved.

— F

#6

hi rubies,
I’m very new to ROR. I’m following some tutorial
for enabling SSL for my rails apllication. In that they have given
plugin installation command like

script/plugin install ssl_requirement

(I’m entering this within my app and i have include ssl_requirement in
my apllication.rb)

When i enter that in my console it gives error like this

/usr/lib/ruby/1.8/timeout.rb:60:in `rbuf_fill’: execution expired
(Timeout::Error)

I don’t know what is that where i’m making mistake… it will be
helpful if you guide me…


#7

Fernando P. wrote:

In you application controller file add:

include SslRequirement

This does not respond to the OP’s actual problem (and one I now have).

At the terminal I see:

==
$ ruby script/plugin install ssl_requirement
Plugin not found: [“ssl_requirement”]

It happens that I do have “include SslRequirement” in my application
controller, but that isn’t the problem. The problem is that
script/plugin can not find the ssl_requirement plugin to install.

This puzzles me, as I’ve installed this plugin in another project a
month ago. It also worries me, as I’ve seen support for other Rails
technologies “disappear” without notice.

I suppose I could simply copy the installed plugin directory from the
other project, but I’d rather do it right. How can I get this to work?

— F