SSL on Heroku


#1

Since Heroku has integrated the piggybank_ssl addon by default, trying:

heroku addons:add piggyback_ssl
or
heroku addons:add ssl:piggyback

results in:
! This add-on is now a standard Heroku platform feature.
! Your apps can already use piggyback SSL.

But accessing: mywebsite.herokuapp.com results in:
SSL is not enabled
mywebsite.herokuapp.com does not have SSL enabled.

And I have the config.force_ssl = true in my production.rb

So, any hint of what i am missing ???


#2

try specifying https on the front of your url… (?)

https://mywebsite.herokuapp.com

Daniel Rove wrote in post #1049029:

Since Heroku has integrated the piggybank_ssl addon by default, trying:

heroku addons:add piggyback_ssl
or
heroku addons:add ssl:piggyback

results in:
! This add-on is now a standard Heroku platform feature.
! Your apps can already use piggyback SSL.

But accessing: mywebsite.herokuapp.com results in:
SSL is not enabled
mywebsite.herokuapp.com does not have SSL enabled.

And I have the config.force_ssl = true in my production.rb

So, any hint of what i am missing ???