Ssl and lightpdd


#1

can you run a site with ssl on a computer on a router or do you need a
dedicated ip for this?


#2

raj kapila wrote:

can you run a site with ssl on a computer on a router or do you need a
dedicated ip for this?

I believe ssl requires a static IP. Not 100% sure of that however.


#3

Alex W. wrote:

raj kapila wrote:

can you run a site with ssl on a computer on a router or do you need a
dedicated ip for this?

I believe ssl requires a static IP. Not 100% sure of that however.

Well my problem is that when i enable ssl in my lighttpd.conf file and i
go to my site all i get is a blank page regardless if that page requires
ssl.


#4

raj kapila wrote:

Alex W. wrote:

raj kapila wrote:

can you run a site with ssl on a computer on a router or do you need a
dedicated ip for this?

I believe ssl requires a static IP. Not 100% sure of that however.

Well my problem is that when i enable ssl in my lighttpd.conf file and i
go to my site all i get is a blank page regardless if that page requires
ssl.

Since SSL runs on a different port (443), it requires a totally separate
vhost.

here is my config for ssl, and non ssl vhosts:

SSL

$SERVER[“socket”] == “70.87.55.194:443” {
server.document-root = “/home/foobar/public/”

fastcgi.server = (
    ".fcgi" =>
      ( "localhost" =>
        (
          "socket" => 

“/home/lighttpd/var/run/lighttpd-fcgi-mwprod-ssl.socket”,
“bin-path” => “/home/foobar/public/dispatch.fcgi”,
“bin-environment” => ( “RAILS_ENV” => “production” ),
“max-load-per-proc” => 25,
“min-procs” => 1,
“max-procs” => 4,
“idle-timeout” => 30
)
)
)

#### SSL engine
ssl.engine                  = "enable"
ssl.pemfile                 = "/home/lighttpd/foobar.com.pem"

}

$HTTP[“host”] =~ “foobar” {
server.document-root = “/home/foobar/public/”
fastcgi.server = (
“.fcgi” =>
( “localhost” =>
(
“socket” =>
“/home/lighttpd/var/run/lighttpd-fcgi-mwprod.socket”,
“bin-path” => “/home/foobar/public/dispatch.fcgi”,
“bin-environment” => ( “RAILS_ENV” => “production” ),
“max-load-per-proc” => 25,
“min-procs” => 1,
“max-procs” => 4,
“idle-timeout” => 30
)
)
)
}

hope it helps


#5

Since SSL runs on a different port (443), it requires a totally separate
vhost.

can i do all this behind a router?


#6

got it working, thanks for you help. I am running behind a router too.
most important part to lighttpd.conf is:

SSL

$SERVER[“socket”] == “70.87.55.194:443” {
server.document-root = “/home/foobar/public/”

fastcgi.server = (
    ".fcgi" =>
      ( "localhost" =>
        (
          "socket" =>

“/home/lighttpd/var/run/lighttpd-fcgi-mwprod-ssl.socket”,
“bin-path” => “/home/foobar/public/dispatch.fcgi”,
“bin-environment” => ( “RAILS_ENV” => “production” ),
“max-load-per-proc” => 25,
“min-procs” => 1,
“max-procs” => 4,
“idle-timeout” => 30
)
)
)

#### SSL engine
ssl.engine                  = "enable"
ssl.pemfile                 = "/home/lighttpd/foobar.com.pem"

}