SQLite3-Ruby version 1.2.3 Installed, SQLite::Database prob

I was trying to install SQLite3 and after a lot of goof ups I’ve managed
to install the gem (SQLite3-Ruby --version 1.2.3). I downloaded the
SQLite3 DLLs and exe and placed them in the System32 folder as well. I
get no errors but when I try to run my code (Just a check to see if its
successfully installed)

require ‘rubygems’
require ‘sqlite3’
puts “Its all okay2” if defined?(SQLITE3::Database)
puts "Something is wrong " unless defined?(SQLITE3::Database)

I get the ‘something is wrong’ message. I can’t figure out if I’ve
messed up some installation step because I read that the latest SQLite3
gem does not have binaries for Windows.

Help!

Sid

Im sorry I think I got it
Sorry

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs