SQLite3 error

I am trying to install SQLite3 on my Rails app but I keep getting this
error:

./sqlite3.dll: 127: The specified procedure could not be found. –
Init_sqlite3 (LoadError)

On Mon, Apr 7, 2008 at 10:49 PM, Matt Murphy
[email protected] wrote:

I am trying to install SQLite3 on my Rails app but I keep getting this
error:

./sqlite3.dll: 127: The specified procedure could not be found. -
Init_sqlite3 (LoadError)

Did you install sqlite3 (from http://www.sqlite.org/download.html) in
addition to the sqlite3-ruby gem?

–wpd

I downloaded both the SQLite3.exe, SQLite3.def, and SQLite3.dll files
and placed them in my Ruby path directory: C:\ruby\bin if that’s what
you mean.

I have the same issue for both v3.5.7 and 3.5.4

The gem install sqlite3-ruby works fine.

Matt

OK, I think I found out what was wrong. I installed the gem before I
placed the dll, exe and def files into my ruby bin directory.

Thanks,
Matt

Matt Murphy wrote:

I downloaded both the SQLite3.exe, SQLite3.def, and SQLite3.dll files
and placed them in my Ruby path directory: C:\ruby\bin if that’s what
you mean.

I have the same issue for both v3.5.7 and 3.5.4

The gem install sqlite3-ruby works fine.

Matt

Also when I run this command:
“c:\ruby\bin\ruby.exe” “c:\ruby\bin\gem” install sqlite3

as seen in step 2 with windows here:
http://wiki.rubyonrails.org/rails/pages/HowtoUseSQLite

I get this error message:
ERROR: could not find sqlite3 locally or in a repository

Matt

Here’s something interesting, it will work if I load up the app normally
(ie start webrick) however if I package the app using tar2rubyscript and
it becomes a single .rb file, when loading that up, I get the error…

Matt Murphy wrote:

OK, I think I found out what was wrong. I installed the gem before I
placed the dll, exe and def files into my ruby bin directory.

Thanks,
Matt

Nevermind, damned error came back again.

127: The specified procedure could not be found. - Init_sqlite3
C:/…/app/sqlite3.dll

.
.
.

This error occurred while loading the following files:
sqlite3

Matt Murphy wrote:

Here’s something interesting, it will work if I load up the app normally
(ie start webrick) however if I package the app using tar2rubyscript and
it becomes a single .rb file, when loading that up, I get the error…

Problem resolved. Had to upgrade to the newest versions of Ruby 1.8.6,
Ruby Gems 1.1.0, & Rails 2.0.2 (with SQLite 3.5.7)

http://www.matts411.com/webdev/ruby_on_rails_standalone_how_to

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs