Sqlite - 2 installazioni - quale usa rails?


#1

Ciao! Sentite, volevo aggiornare sqlite a 3.6, e non volendo fa casini
sulla versione usata da mac os x, ho installato una nuova versione con
macports sotto:

/opt/local/bin/

rails chiaramente invece è quello di mac os x, quindi sotto:

/usr/bin/

se nel terminale scrivo

sqlite3

esce SQLite version 3.6.11, quindi da terminale l’accesso diretto è
giusto.

Ora, come faccio io a sapere se anche Rails userà la 3.6.11 e non la
3.4.0 installata in /usr/bin/?

E se usa la 3.4.0, come faccio a dirgli di usare la 3.6.11?

Qualcuno mi illumina? :slight_smile:


#2

Luca R. wrote:

E se usa la 3.4.0, come faccio a dirgli di usare la 3.6.11?

Qualcuno mi illumina? :slight_smile:

Ciao, dalla versione della gemma?


#3

Ciao, non sono molto esperto di rails, ma se intendi

sqlite3-ruby (1.2.1)

non è forse un semplice collegamento? A me interessa sapere proprio se
questa gemma usa sqlite 3.4.0 o 3.6.11.

O mi sfugge qualcosa? :stuck_out_tongue:

Marco M. wrote:

Luca R. wrote:

E se usa la 3.4.0, come faccio a dirgli di usare la 3.6.11?

Qualcuno mi illumina? :slight_smile:

Ciao, dalla versione della gemma?


#4

Luca R. wrote:

Ciao, non sono molto esperto di rails, ma se intendi

sqlite3-ruby (1.2.1)

non è forse un semplice collegamento? A me interessa sapere proprio se
questa gemma usa sqlite 3.4.0 o 3.6.11.

O mi sfugge qualcosa? :stuck_out_tongue:

Si hai ragione la versione della gemma non c’entra nulla.
Su win piazzi la dll nella bin dell’installazione ruby che poi decidi
quale usare dal progetto rails ma non so come faccia l’ide che utilizzo
(netbeans) ad associare il mio progetto rails alla piattaforma ruby, non
ho trovato nulla.


#5

Ok sperimenterò io e poi se mi ricordo vi faccio sapere :wink:

Marco M. wrote:

Luca R. wrote:

Ciao, non sono molto esperto di rails, ma se intendi

sqlite3-ruby (1.2.1)

non è forse un semplice collegamento? A me interessa sapere proprio se
questa gemma usa sqlite 3.4.0 o 3.6.11.

O mi sfugge qualcosa? :stuck_out_tongue:

Si hai ragione la versione della gemma non c’entra nulla.
Su win piazzi la dll nella bin dell’installazione ruby che poi decidi
quale usare dal progetto rails ma non so come faccia l’ide che utilizzo
(netbeans) ad associare il mio progetto rails alla piattaforma ruby, non
ho trovato nulla.