Sql server 2000 with ruby on rails works?

'm trying to use Ruby on Rails accessing a pre-existing database on
SQL Server 2000.
After some research I found that it should use the gem activerecord-
sqlserver-adapter. Create a connection via ODBC to the
desired base, and creating a database user for access it. We also
configured the database.yml in the following ways:
development:
adapter: sqlserver
mode: odbc
dsn: mydsn;
Server = my_server_name;
username: myuser
password:

this is my database.yml

above config works fine for MS SQL 2005 SUCCESSFULLY. But i want to
work with MSSQL 2000. please provide some help.

On Mar 10, 2011, at 11:59 PM, “Er.SALIM MANDREKAR”
[email protected] wrote:

Server = my_server_name;
username: myuser
password:

this is my database.yml

above config works fine for MS SQL 2005 SUCCESSFULLY. But i want to
work with MSSQL 2000. please provide some help

What error are you receiving when you try to connect to SQL server 2000?

B.

i’m getting RAKE ABORTED!!! ERROR.

n after this i get message in command prompt saying only MS SQL SERVER
2005
AND LATER ARE SUPPORTED…

I INSTALLED THE GEM WHICH IS FOR SQL SERVER 2000.

BUT STILL THE SAME.

a post I did a while ago…
Maybe an older version of activerecord-sqlserver-adapter?

http://johnivanoff.blogspot.com/2010/03/new-ruby-on-rails-setup-on-windows-xp.html

also goo.gl/vvGuH

Cheers
John I.
I’ve registered for the Bike MS: SAM’S CLUB Ride to fulfill a personal
challenge, and also to help the National MS Society fund research,
advocate for change and help people with MS and their families lead
powerful lives. I believe in the work they do and want to be part of
it.

Can I count on your help? http://goo.gl/Iw3Y ||
http://main.nationalmssociety.org/site/TR/Bike/TXHBikeEvents?px=5933747&pg=personal&fr_id=16031

On Mar 11, 2:50am, “Er.SALIM MANDREKAR” [email protected]

On Fri, Mar 11, 2011 at 2:50 AM, Er.SALIM MANDREKAR <
[email protected]> wrote:

i’m getting RAKE ABORTED!!! ERROR.

n after this i get message in command prompt saying only MS SQL SERVER 2005
AND LATER ARE SUPPORTED…

I INSTALLED THE GEM WHICH IS FOR SQL SERVER 2000.

BUT STILL THE SAME.

Well the error message is pretty clear. It corresponds to what is
written in
the documentation for activerecord-sqlserver-adapter:

“This gem should support SQL Server 2005 but not 2000 because of type
changes.”

This gem is not going to do what you want it to do. Instead you should
try
using the gem rails-sqlserver-adapter which does, accordind to its
documentation, support SQL Server 2000.

https://github.com/adzap/rails-sqlserver-adapter

B.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs