Spending the whole day to build gnuradio on a Mac?

Mac OSX 10.10.4
gnuradio 3.7.7.1 homebrew
Trying to get the SDPplay to work using gr-osmosdr

I tried an innocent brew install gnuradio. That went wrong on the fact
that
gnuradio was compiled against the homebrew python and when launched uses
the Darwin python as discussed here:
https://github.com/titanous/homebrew-gnuradio/issues/7. Haven’t found a
good solution to that problem yet.

Then i used the workaround to export
DYLD_FRAMEWORK_PATH=/usr/local/lib:$DYLD_FRAMEWORK_PATH, uninstalled
gnuradio and installed it again. That went ok until i built gr-osmosdr
with
the ENABLE_NONFREE option. Then the problem came back again.

Then i tried to build gnuradio from source hoping it would use the
system
python and the problem would go away. That took a few hours only to
result
in the same error.

So i removed all the dependencies and built those from source as well.
Now
when building gnuradio i get the following error:
==> cmake … -DCMAKE_PREFIX_PATH=/usr/local/Cellar/gnuradio/3.7.7.1
-DENABLE_DOXYGEN=Off -DCMAKE_C_COMPILER=clang -DCMAKE_CXX_COMPIL
==> make
==> make install
Error: No such file or directory - /usr/local/Cellar/gnuradio/
3.7.7.1/etc/gnuradio/conf.d/grc.conf

What’s going on? Is there not a relative simple way to build gnuradio on
a
Mac? I got all those problems while following the instructions on
https://github.com/metacollin/homebrew-gnuradio

Any suggestions would be appreciated,

Ton.

Hi Ton - As always, I recommend using MacPorts to do your dirty work;
check out the GR install guide
http://gnuradio.org/redmine/projects/gnuradio/wiki/MacInstall . Once
‘port’ is installed, getting GR is as simple as “sudo port install
gnuradio”.

For sdrplay: If you check out the Gqrx forum, you’ll find a related
discussion here:
https://groups.google.com/forum/#!topic/gqrx/OtTNWVTTjFU . I offer a
patch for MacPorts’ gr-osmosdr port that installs sdrplay as an optional
variant. What the OP found is, and this is not a great surprise, is that
sdrplay isn’t really ready for OSX yet.

You can use Homebrew for GR, and a few folks I know do. I prefer to not
do that, because Homebrew installs into /usr/local, which is a standard
search path for most Unix-y tools & is prone to being found before other
paths.

I you want specific help, email me off list. Homebrew is not my
specialty, but I’ll do what I can.

Good luck! - MLD

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs