Specifying Active Support Version in environment.rb

Hello.

I am getting this error…

C:/dev/ccx_aucxtion_ccx/config/boot.rb:20:Warning:
Gem::SourceIndex#search support for String patterns is deprecated
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate’: can’t
activate activesupport (= 1.4.4, runtime), already activated active
support-2.2.2 (Gem::Exception)

Is there a way to specify the Active Support version in
environment.rb? I see there is a way to specify the Rails version…

RAILS_GEM_VERSION = ‘1.2.6’ unless defined? RAILS_GEM_VERSION

Please let me know.
Thanks,
John

On 2 Jan 2009, at 16:50, John wrote:

support-2.2.2 (Gem::Exception)

Is there a way to specify the Active Support version in
environment.rb? I see there is a way to specify the Rails version…

A particular version of rails is tied to a particular version of
activesupport. The error message you’ve got means that something
required a newer version of activesupport before rails loaded its
version.

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs