Something about Homebrew install ruby

I installed the ruby1.8.7 by macports.
Yesterday, I updated the ruby into 1.9.1 by homebrew.
But when I show the version (ruby -v),It still is 1.8.7. So I use brew
link ruby,and replace the /opt/local/bin/ruby by /usr/local/Cellar/
ruby/1.9.1-p378/bin/ruby. It works. But command “ri” is not work yet.

Is there any way to use the ruby installed by homebrew?

,sorry for my english

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs